Index

TRS内容协作平台(WCM)数据字典

本数据字典包含WCM标准平台及与之一同运行的图片库,表单(不包含infogate应用), 元数据等三个选件在内的数据库表结构的说明.截止整理日期(2009-04-30),系统共有153个表. 数据字典为开发文档，仅限公司内部使用

各表详细信息 E-R对应表

在深入了解每一个表的细节前,有必要了解一下文档的说明风格。

  • 每个表的描述由主要的三部分组成:
    1. 表名:如WCMDOCUMENT表.
    2. 描述:简要说明该表存储的是什么信息
      如果在该部分看到(保留)字样,则表示该表一般情况下不为外部使用.不需要关心其内部细节
    3. 结构:以列表的方式说明表的结构.如下表所示
      表结构说明
      列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
      DOCID | 文档编号 | 默认值 | int | 100
      该表共有七列,每一行描述一个数据表字段的信息。
      1. 列名：字段的名称， [image] 图标表示该列一该表的主键列
      2. 说明：字段的作用简要描述
      3. 默认值：字段的默认取值，如果没有则留空
      4. 表示该字段允许空值，否则必须有值
      5. 类型：字段在mssql中的类型名
      6. 长度：如果该字段的类型是nvarchar，则标识该字段可容纳的字符长度；否则留空
      7. 备注：对于该列的一些补充说明，可能链接到另外一个表，也可能是链接到当前表的备注部分
  • 在表结构的说明之后，可能会有备注部分。该部分是对表结构列的一些补充
  • 表结构中的类型是以mssql类型名表示的，对应于其它数据库的类型名如下表所示
    数据类型对应表
    数据库 | 数据类型
    mssql | int | bigint | smallint | tinyint | (n)varchar | (n)char | datetime | (n)text
    oracle | int | number(38,0) | number(5,0) | number(5,0) | varchar2 | varchar2 | date | clob
    db2 | bigint | decimal(31,0) | int | int | varchar | varchar | timestamp | clob
    sybase | int | bigint | smallint | tinyint | nvarchar | nvarchar | datetime | text
    mysql | int | bigint | smallint | tinyint | nvarchar | nvarchar | datetime | text
  • 对于nvarchar类型的长度，其它数据库对应的长度是mssql的两倍与4000中两个值的小者


Index

文档管理
WCMDOCUMENT | 文档信息
WCMAPPENDIX | 存储文档附件的基本信息，建立系统附件对象和文件系统的文件关联
WCMCONTENTLINK | 系统热词
WCMCONTENTLINKTYPE | 系统热词分类
WCMDOCBAK | 文档的备份,各版本的内容(见 WCMDOCUMENT 表)
WCMDOCKEYWORD | 文档关键词
WCMDOCKIND | 文档的分类信息(保留)
WCMDOCQUOTEIMAGE | 引用图片库图片的文档记录
WCMDOCREPLY | 文档回复 (保留,在EKP等动态应用使用)
WCMDOCSYN | 同步分发已分发文档记录
WCMDOCTYPE | 文档的类型信息(保留)
WCMDOCUMENT | 文档信息
WCMEXPIRATION | 文档的过期处理方式(保留)
WCMRELATION | 相关文档信息
WCMSECURITY | 文档的安全级别
WCMSOURCE | 文档来源
WCMSTATUS | 文档状态信息
WCMFILETYPE | 文档附件的类型信息(保留)
XWCMWATERMARK | 图片库:水印信息
WCMHITSCOUNT | 点击数
WCMRECENT | 用户最近操作对象保留
XWCMDOCUMENTTOPIC | 文档评论(评论选件)
XWCMTOPICEDDOCRELATION | 文档与文档评论的关联关系
站点管理
WCMCHANNEL | 存储频道(栏目)的基本信息
WCMCHANNELCONTENTLINK | 栏目热词信息
WCMCHANNELSYN | 存储频道的同步分发信息
WCMCHNLDOC | 栏目和文档之间的关联信息
WCMCHNLEXTFIELD | 栏目与扩展字段的关联信息(保留,现在使用 WCMCONTENTEXTFIELD表)
WCMCHNLFLOW | 栏目与工作流关联关系(保留,见 WCMFLOWEMPLOY表)
WCMCHNLTEMP | 栏目与模板关联关系(保留 ,见 WCMTEMPLATEEMPLOY表)
WCMEXTFIELD | 系统扩展字段
WCMREPLACE | 替换内容
WCMSITEEXTFIELD | 站点扩展字段(保留)
WCMSITEUSER | 站点用户/用户组/角色等信息
WCMWEBSITE | 站点信息
WCMAUTOBAKCONFIG | 存储文档版本自动保存配置信息
WCMCONTENTEXTFIELD | 扩展字段使用关联信息 表示扩展字段被哪个栏目/站点使用
XWCMLOGO | 栏目/文档标记图信息
工作流管理
WCMCONDITIONBEAN | 条件工件流驱动(保留)
WCMFLOW | 工作流信息
WCMFLOWACTION | 工作流操作的基本信息
WCMFLOWBRANCH | 工作流连线(分支)的基本信息
WCMFLOWCONTENTCONFIG | 可流转内容对象配置
WCMFLOWDOC | 工作流和文档的关联信息
WCMFLOWDOCBAK | 文档与工作流的关联关系(流转轨迹)
WCMFLOWEMPLOY | 使用工作流的对象
WCMFLOWEVENTCONDITION | 保留
WCMFLOWEVENTOPERATE | 保留
WCMFLOWMONOPER | 保留
WCMFLOWNODE | 工件流节点信息
WCMFLOWNODEEVENT | 保留
WCMFLOWNODEOPER | 保留
XWCMFLOWACTION | 工作流节点上执行的动作
XWCMFLOWCONDITION | 工作流操作条件
XWCMFLOWDOCLOG | 流转文档日志记录
XWCMFLOWNODEFIELD | 工流节点相关字段(自定义表单)
XWCMFLOWRULE | 工作流规则
发布相关信息
WCMCHANNELCHILDINDEXQUOTE | 栏目引用关联信息：触发发布内容
WCMFOLDERPUBLISHCONFIG | 发布属性配置信息
WCMFOLDERPUBLISHINFO | 发布属性配置,FACAD对象(保留)
WCMPUBLISHCONFIG | 发布属性配置,FACAD对象(保留)
WCMPUBLISHDISTRIBUTION | 发布分发
WCMPUBLISHERRORLOG | 发布错误日志信息
WCMPUBLISHTASK | 发布任务信息
WCMPUBSTATUSCONFIG | 可发布状态配置信息
WCMTEMPAPDREL | 模板附件关联关系
WCMTEMPAPPENDIX | 模板附件
WCMTEMPLATE | 模板
WCMTEMPLATEARGUMENT | 模板变量
WCMTEMPLATEEMPLOY | 模板配置使用信息
WCMTEMPLATENEST | 嵌套模板信息
WCMTEMPLATEQUOTE | 模板引用信息
自定义表单
WCMEXCELDATA | 自定义表单数据(保留
WCMFORMFIELDS | 自定义表单字段信息(保留)
WCMFORMINFO | 自定义表单信息 (保留)
WCMINFOVIEW | 自定义表单信息(InfoPath)
WCMINFOVIEWEMPLOY | 自定义表单与使用者的关联关系信息
WCMINFOVIEWFIELD | 自定义表单字段信息
WCMINFOVIEWGROUP | 自定义表单内部数据分组
WCMINFOVIEWSERIAL | 自定义表单序号信息维护
WCMINFOVIEWVIEW | 自定义表单视图
元数据
XWCMCLASSINFO | 元数据选件:分类法
XWCMCLASSINFOVIEW | 元数据: 分类视图模式下的数据关联信息
XWCMCOMPLEXFIELDDATA | 元数据:复杂字段数据
XWCMDBFIELDINFO | 元数据:元数据表字段信息
XWCMMETADATA | 元数据:元数据数据关联信息
XWCMMETAVIEWEMPLOYER | 元数据:视图与栏目的关联信息
XWCMTABLEINFO | 元数据:元数据表信息
XWCMVIEWFIELDINFO | 元数据:视图字段信息
XWCMVIEWINFO | 元数据:视图信息
XWCMVIEWOTHERTABLES | 元数据:视图与非主表关联信息
权限认证
WCMUSER | 用户信息
WCMGROUP | 系统用户组信息
WCMGRPUSER | 用户与用户组的关联关系
WCMROLE | 系统角色信息
WCMROLEUSER | 系统用户与角色的关联类系
WCMRIGHT | 权限信息
WCMRIGHTDEF | 权限定义
WCMTRUSTEEINFO | 用户托管的信息(保留)
计划任务
WCMJOB | 系统定时任务信息(保留)
WCMJOBEXERESULT | 系统定时任务执行结果
WCMSCHEDULE | 系统计划任务信息
WCMOBJTRIGGER | 定时任务触发器(保留)
WCMOPER | 系统操作类型
WCMOPERATIONBEAN | 系统操作BEAN(保留)
系统配置
WCMCONFIG | 系统配置
WCMDBUPDATE | WCM系统数据库更新记录表(保留)
WCMDBUPDATELOG | WCM系统数据库更新日志记录(保留)
WCMID | WCM对象编号维护信息
WCMLOG | 操作日志信息
WCMLOGBAK | 日志备份表(见WCMLOG表)
WCMLOGTYPE | 日志类型
WCMTAGBEANS | 模板置标解释Bean
WCMSECUREKEY | 系统私/公钥信息
WCMHELP | 系统帮助 (保留)
WCMOPERTYPE | 系统操作类型信息
XWCMENTRYCONFIG | WCM选件系统配置
XWCMPAGEOPERATOR | 面板操作设置
统计相关
WCMSTATFIELDMAP | 统计表字段映射
WCMSTATHOST | 统计主体
WCMSTATVIEW | 统计视图
WCMSTATVIEWREL | 统计视图关联关系
WCMSTAT_CHANNEL_GENERAL | 统计表(保留)
WCMSTAT_CHANNEL_TEMPLATE | 统计表(保留)
WCMSTAT_DOCSOURCE_PUBALL | 统计表(保留)
WCMSTAT_GROUP_GENERAL | 统计表(保留)
WCMSTAT_SITE_GENERAL | 统计表(保留)
WCMSTAT_USER_GENERAL | 统计表(保留)
WCMSTAT_WORKFLOW_GROUP_GENERAL | 统计表(保留)
WCMSTAT_WORKFLOW_USER_GENERAL | 统计表(保留)
个人信息服务
WCMADDRESS | 存储系统用户的个人通讯录信息
WCMADDRGROUP | 存储系统用户的个人通讯组信息
WCMADDRGRPMAP | 存储系统用户的个人通讯录和通讯组的关联
WCMBOOKMARK | 存储系统用户的个人书签
WCMBULLETIN | 存储系统的公告板和留言板内容
WCMCONTACT | 统用户的联系人信息
WCMCONTGROUP | 系统联系人组信息
WCMCONTGRPMAP | 联系人和联系人组之间的关联
WCMEVENT | 系统的日程表事件
WCMEVENTSHARE | 事件共享信息
WCMEVENTTYPE | 事件类型信息
WCMMARKKIND | 书签文件夹(分类)信息
WCMMARKSHARE | 共享书签信息
WCMMEETINGCONT | 网络会议的内容(保留)
WCMMEETINGROOM | 网络会议室
WCMMEETINGUSER | 网络会议的参加用户
WCMMESSAGE | 在线短消息记录
WCMMSGQUEUE | 消息分发信息
WCMMSGRECEIVER | 消息接收者信息
WCMTASK | 日程安排中的任务信息
WCMTASKPOOL | 日程安排中的任务共享
WCMUSERSETTING | 用户个性化定义
XWCMINDIVIDUATION | 用户个性化定义设置


Index

TRS内容协作平台(WCM)数据字典

E-R Mapping
表名 | OBJ_TYPE | Enty-Class
WCMAPPENDIX | 601 | com.trs.components.wcm.content.persistent.Appendix
WCMAUTOBAKCONFIG | 902 | com.trs.components.wcm.content.persistent.AutoBakConfig
WCMBOOKMARK | 303 | com.trs.components.common.bookmark.BookMark
WCMCHANNEL | 101 | com.trs.components.wcm.content.persistent.Channel
WCMCHANNELCONTENTLINK | 1952046669 | com.trs.components.wcm.content.persistent.ChannelContentLink
WCMCHANNELSYN | 903 | com.trs.components.wcm.content.persistent.ChannelSyn
WCMCONFIG | 701 | com.trs.infra.support.config.Config
WCMCONTACT | 304 | com.trs.components.common.address.Contact
WCMCONTENTEXTFIELD | 1319922479 | com.trs.components.wcm.content.persistent.ContentExtField
WCMCONTENTLINK | 106 | com.trs.components.wcm.content.persistent.ContentLink
WCMCONTENTLINKTYPE | 68828714 | com.trs.components.wcm.content.persistent.ContentLinkType
WCMCONTGROUP | 305 | com.trs.components.common.address.ContactGrp
WCMDBUPDATELOG | 3001 | com.trs.db.update.DBUpdateLog
WCMDOCBAK | 611 | com.trs.components.wcm.content.persistent.DocBak
WCMDOCKIND | 602 | com.trs.components.wcm.resource.DocKind
WCMDOCREPLY | 603 | com.trs.components.wcm.content.persistent.DocReply
WCMDOCSYN | -20395414 | com.trs.components.wcm.content.persistent.DocumentSyn
WCMDOCUMENT | -1 | com.trs.components.infoview.persistent.InfoViewDocument
WCMDOCUMENT | -1 | com.trs.components.wcm.content.ViewDocument
WCMDOCUMENT | 605 | com.trs.components.wcm.content.persistent.Document
WCMEVENT | 306 | com.trs.components.common.calendar.Event
WCMEVENTSHARE | 1373899236 | com.trs.components.common.calendar.EventShare
WCMEVENTTYPE | 313 | com.trs.components.common.calendar.EventType
WCMEXCELDATA | 612 | com.trs.wcm.old.WCMExcelData
WCMEXTFIELD | 4 | com.trs.cms.content.ExtendedField
WCMFILETYPE | 604 | com.trs.components.wcm.resource.FileType
WCMFLOW | 401 | com.trs.cms.process.definition.Flow
WCMFLOWBRANCH | 404 | com.trs.cms.process.definition.FlowNodeBranch
WCMFLOWCONTENTCONFIG | 2069049653 | com.trs.cms.process.engine.FlowContentConfig
WCMFLOWDOC | 405 | com.trs.cms.process.engine.FlowDoc
WCMFLOWDOCBAK | 406 | com.trs.cms.process.engine.FlowDocBak
WCMFLOWEMPLOY | 30001 | com.trs.cms.process.definition.FlowEmploy
WCMFLOWNODE | 403 | com.trs.cms.process.definition.FlowNode
WCMFOLDERPUBLISHCONFIG | 956 | com.trs.components.common.publish.persistent.publisher.FolderPublishConfig
WCMFOLDERPUBLISHINFO | 1326635776 | com.trs.components.wcm.publish.WCMFolderPublishConfig
WCMFORMFIELDS | 1002 | com.trs.wcm.old.WCMFormFields
WCMFORMINFO | 1001 | com.trs.wcm.old.WCMFormInfo
WCMGROUP | 201 | com.trs.cms.auth.persistent.Group
WCMGRPUSER | -1209578322 | com.trs.cms.auth.persistent.GroupUser
WCMHELP | 1458815411 | com.trs.components.wcm.wcmx.help.WCMHelp
WCMHITSCOUNT | 613 | com.trs.components.wcm.content.persistent.HitsCount
WCMINFOVIEW | 1104 | com.trs.components.infoview.persistent.InfoView
WCMINFOVIEWEMPLOY | 1106 | com.trs.components.infoview.persistent.InfoViewEmploy
WCMINFOVIEWFIELD | 1105 | com.trs.components.infoview.persistent.InfoViewField
WCMINFOVIEWGROUP | 1107 | com.trs.components.infoview.persistent.InfoViewGroup
WCMINFOVIEWVIEW | 1108 | com.trs.components.infoview.persistent.InfoViewView
WCMJOBEXERESULT | -1 | com.trs.infra.util.job.JobFailedResult
WCMLOGBAK | 805 | com.trs.infra.support.log.LogBak
WCMMARKKIND | 307 | com.trs.components.common.bookmark.MarkKind
WCMMARKSHARE | 308 | com.trs.components.common.bookmark.MarkShare
WCMMESSAGE | 309 | com.trs.components.common.message.Message
WCMMSGQUEUE | 310 | com.trs.components.common.message.MsgQueue
WCMMSGRECEIVER | 10003 | com.trs.components.common.message.MsgReceiver
WCMOPER | -463614381 | com.trs.components.common.job.JobWorkerType
WCMOPERTYPE | 123456 | com.trs.infra.support.log.OperType
WCMPUBLISHDISTRIBUTION | 955 | com.trs.components.common.publish.persistent.distribute.PublishDistribution
WCMPUBLISHERRORLOG | 106 | com.trs.components.common.publish.persistent.taskdispatch.PublishErrorLog
WCMPUBLISHTASK | 105 | com.trs.components.common.publish.persistent.taskdispatch.PublishTask
WCMPUBSTATUSCONFIG | 864684658 | com.trs.components.wcm.publish.WCMPubStatusConfig
WCMRECENT | 315 | com.trs.components.wcm.recent.Recent
WCMRELATION | 609 | com.trs.components.wcm.content.persistent.Relation
WCMREPLACE | 105 | com.trs.components.wcm.content.persistent.Replace
WCMRESULTSET | 1000 | com.trs.infra.persistent.CMyResultSet
WCMRIGHTDEF | 205 | com.trs.cms.auth.persistent.RightDef
WCMROLE | 203 | com.trs.cms.auth.persistent.Role
WCMROLEUSER | -1643208931 | com.trs.cms.auth.persistent.RoleUser
WCMSCHEDULE | 501 | com.trs.components.common.job.Schedule
WCMSECUREKEY | 559084253 | com.trs.infra.support.security.SecureKey
WCMSECURITY | 607 | com.trs.components.wcm.resource.Security
WCMSITEUSER | 1071614564 | com.trs.components.wcm.content.persistent.SiteMember
WCMSOURCE | 608 | com.trs.components.wcm.resource.Source
WCMSTATFIELDMAP | 1042580721 | com.trs.components.wcm.stat.StatFieldMap
WCMSTATHOST | 486152215 | com.trs.components.wcm.stat.StatHost
WCMSTATUS | 610 | com.trs.components.wcm.resource.Status
WCMSTATVIEW | 486563092 | com.trs.components.wcm.stat.StatView
WCMSTATVIEWREL | 313468187 | com.trs.components.wcm.stat.StatViewRel
WCMTAGBEANS | 951 | com.trs.components.common.publish.persistent.template.TagBean
WCMTEMPAPDREL | 952 | com.trs.components.common.publish.persistent.template.TempApdRel
WCMTEMPAPPENDIX | 104 | com.trs.components.common.publish.persistent.template.TempAppendix
WCMTEMPLATE | 102 | com.trs.components.common.publish.persistent.template.Template
WCMTEMPLATEARGUMENT | 957 | com.trs.components.common.publish.persistent.template.TemplateArgument
WCMTEMPLATEEMPLOY | 953 | com.trs.components.common.publish.persistent.template.TemplateEmploy
WCMTEMPLATEQUOTE | 954 | com.trs.components.common.publish.persistent.template.TemplateQuote
WCMTRUSTEEINFO | 206 | com.trs.cms.auth.persistent.TrusteeInfo
WCMUSER | 204 | com.trs.cms.auth.persistent.User
WCMUSERSETTING | 314 | com.trs.components.wcm.customize.UserSetting
WCMWEBSITE | 103 | com.trs.components.wcm.content.persistent.WebSite
XWCMADCOM | 2024 | com.trs.components.common.trsad.ADCom
XWCMADFILE | 2023 | com.trs.components.common.trsad.ADFile
XWCMADFILEPOS | 2027 | com.trs.components.common.trsad.ADFilePos
XWCMADPOS | 2026 | com.trs.components.common.trsad.ADPos
XWCMADTYPE | 2028 | com.trs.components.common.trsad.ADType
XWCMCLASSINFO | 694710472 | com.trs.components.metadata.definition.ClassInfo
XWCMCLASSINFOVIEW | 1787436547 | com.trs.components.metadata.center.ClassInfoView
XWCMCOMPLEXFIELDDATA | 1768965483 | com.trs.components.infoview.helper.ComplexFieldData
XWCMDBFIELDINFO | 1269981572 | com.trs.components.metadata.definition.MetaDBField
XWCMDOCUMENTTOPIC | 1723559682 | com.trs.components.comment.persistent.DocumentTopic
XWCMENTRYCONFIG | 1640423776 | com.trs.components.common.conjection.persistent.EntryConfig
XWCMFLOWACTION | 79689646 | com.trs.cms.process.definition.FlowAction
XWCMFLOWCONDITION | 2142183261 | com.trs.cms.process.definition.FlowCondition
XWCMFLOWDOCLOG | 1935654805 | com.trs.cms.process.definition.FlowdocLog
XWCMFLOWNODEFIELD | 1813441049 | com.trs.cms.process.definition.FlowNodeField
XWCMFLOWRULE | 201723508 | com.trs.cms.process.definition.FlowRule
XWCMINDIVIDUATION | 1576803201 | com.trs.components.wcm.individuation.Individuation
XWCMLOGO | 1718600976 | com.trs.components.wcm.publish.logo.Logo
XWCMMEDIAREMINDEDINFO | 4001 | com.trs.components.wcm.wcmx.media.MediaRemindedInfo
XWCMMETAVIEWEMPLOYER | 1569209521 | com.trs.components.metadata.center.MetaViewEmployer
XWCMPAGEOPERATOR | 1766746836 | com.trs.wcm.config.PageOperator
XWCMTABLEINFO | 1621427854 | com.trs.components.metadata.definition.MetaDBTable
XWCMTOPICEDDOCRELATION | 1589400188 | com.trs.components.comment.persistent.TopicedDocRelation
XWCMVIEWFIELDINFO | 1886731157 | com.trs.components.metadata.definition.MetaViewField
XWCMVIEWINFO | 1874605631 | com.trs.components.metadata.definition.MetaView
XWCMVOTE | 2099 | com.trs.components.common.trsvote.Vote
XWCMVOTEDATA | 2102 | com.trs.components.common.trsvote.VoteData
XWCMVOTEIPLOG | 2103 | com.trs.components.common.trsvote.VoteIPLog
XWCMVOTEITEM | 2100 | com.trs.components.common.trsvote.VoteItem
XWCMVOTEOPTION | 2101 | com.trs.components.common.trsvote.VoteOption
XWCMWATERMARK | 1377689707 | com.trs.wcm.photo.Watermark
unknown | -1 | com.trs.ajaxservice.ContentExtendValue
unknown | -1 | com.trs.cms.auth.persistent.Right
unknown | -1 | com.trs.cms.content.CMSObjDefaultImpl
unknown | 8888 | com.trs.cms.content.DefaultObj
unknown | 1 | com.trs.cms.content.WCMSystemObject
unknown | 3013 | com.trs.components.infoview.persistent.InfoViewData
unknown | 1936280531 | com.trs.components.metadata.center.MetaViewData
unknown | -1 | com.trs.components.wcm.content.persistent.ChnlDoc
unknown | -1 | com.trs.components.wcm.content.persistent.XDocument
unknown | -1 | com.trs.infra.persistent.MyBaseObj
unknown | -1 | com.trs.infra.support.log.Log


WCMADDRESS

WCMADDRESS表：

描述：

存储系统用户的个人通讯录信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ADDRID | 个人通讯录编号 |  |  | int |  |
OBJTYPE | 通讯录对象的类型 |  |  | smallint |  |
OBJID | 通讯录对象的编号 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMADDRGROUP

WCMADDRGROUP表：

描述：

存储系统用户的个人通讯组信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
GROUPID | 个人通讯组编号 |  |  | int |  |
GNAME | 通讯组名称 |  |  | nvarchar | 200 |
GDESC | 通讯组描述 |  |  | nvarchar | 200 |
ATTRIBUTE | 通讯组的扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMADDRGRPMAP

WCMADDRGRPMAP表：

描述：

存储系统用户的个人通讯录和通讯组的关联

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ADDRID | 个人通讯录编号 |  |  | int |  | WCMADDRESS.ADDRID
GROUPID | 个人通讯组编号 |  |  | int |  | WCMADDRGROUP.GROUPID
ATTRIBUTE | 关联的扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMAPPENDIX

WCMAPPENDIX表：

描述：

存储文档附件的基本信息，建立系统附件对象和文件系统的文件关联

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
APPENDIXID | 文档附件编号 |  |  | int |  |
APPDOCID | 文档附件所属的文档编号 |  |  | int |  | WCMDOCUMENT.DOCID
APPFILE | 对应的文件系统文件名 |  |  | nvarchar | 255 |
APPFILETYPE | 文档附件的文件类型 | -1 |  | int |  |
APPDESC | 文档附件的描述 |  |  | nvarchar | 255 |
APPLINKALT | 文档附件的页面ALT |  |  | nvarchar | 255 |
APPSERN | 文档附件在文档中的序号 |  |  | int |  |
APPPROP | 文档附件的属性 |  |  | int |  |
APPFLAG | 文档附件的标记 |  |  | smallint |  |
APPTIME | 文档附件的时间 |  |  | datetime |  |
APPAUTHOR | 文档附件的作者 |  |  | nvarchar | 100 |
APPEDITOR | 文档附件的编者 |  |  | nvarchar | 100 |
ATTRIBUTE | 文档附件的扩展属性 |  |  | nvarchar | 500 |
USEDVERSIONS | 文档附件的版本号 | 1 |  | numeric |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
SRCFILE | 文档附件的原文件名 |  |  | nvarchar | 200 |
FILEEXT | 文档附件的扩展名 |  |  | nvarchar | 20 |
ISIMPORTTOIMAGELIB | 附件是否来自图片库 | 0 |  | int |  | 图片库
RELATEDCOLUMN | --列说明-- |  |  | varchar | 200 |

备注:

  1. 图片库：当且仅当有图片库选件时有效。值为1时表示是来自图片库


WCMAUTOBAKCONFIG

WCMAUTOBAKCONFIG表：

描述：

存储文档版本自动保存配置信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
AUTOBAKCONFIGID | 配置编号 |  |  | int |  |
SITEID | 配置所属站点编号 标示配置作用于那个站点 |  |  | int |  | WCMWEBSITE.SITEID
OPERTYPE | 触发自动保存的操作类型 |  |  | nvarchar | 200 |
DOCSTATUSES | 可以自动保存的文档状态 |  |  | nvarchar | 200 | WCMDOCUMENT.DOCSTATUS
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMBOOKMARK

WCMBOOKMARK表：

描述：

存储系统用户的个人书签

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
MARKID | 书签编号 |  |  | int |  |
MNAME | 书签名称 |  |  | nvarchar | 200 |
MLINK | 书签对应的链接 |  |  | nvarchar | 200 |
MICON | 书签的代表图标 |  |  | nvarchar | 200 |
MKIND | 书签所属的文件夹编号 |  |  | int |  | WCMMARKKIND.KINDID
ATTRIBUTE | 书签的扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMBULLETIN

WCMBULLETIN表：

描述：

存储系统的公告板和留言板内容

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
BULLETINID | 公告或留言编号 |  |  | int |  |
TITLE | 公告或留言标题 |  |  | nvarchar | 200 |
BODY | 公告或留言正文 |  |  | ntext |  |
FLAG | 公告或留言标记 |  |  | smallint |  |
ATTRIBUTE | 公告或留言扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMCHANNEL

WCMCHANNEL表：

描述：

存储频道(栏目)的基本信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CHANNELID | 编号 |  |  | int |  |
SITEID | 所属站点编号 |  |  | int |  | WCMWEBSITE.SITEID
CHNLNAME | 名称(唯一标识) |  |  | nvarchar | 200 | 名称
CHNLDESC | 描述(显示名称) |  |  | nvarchar | 200 |
CHNLTABLE | 数据检索表 |  |  | nvarchar | 200 |
CHNLQUERY | 检索条件 |  |  | nvarchar | 500 |
CHNLPROP | 属性 |  |  | int |  | 属性
PARENTID | 父栏目编号 | 0 |  | int |  | 父编号
CHNLORDER | 序号 | 0 |  | int |  |
SCHEDULE | 计划发布任务编号 |  |  | int |  | 保留,计划发布
CHNLDATAPATH | 存放位置 |  |  | nvarchar | 200 | 保留,存放位置
CHNLORDERBY | 栏目文档排序方式 |  |  | nvarchar | 200 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
STATUS | 状态 | 0 |  | int |  | 状态
CHNLTYPE | 类型 | 0 |  | int |  |
CHNLOUTLINETEMP | 概览模板 | 0 |  | int |  | 保留
CHNLDETAILTEMP | 细览模板 | 0 |  | int |  |
PUBLISHPRO | 发布属性 | 1 |  | smallint |  |
OPERUSER | 删除栏目的操作用户 |  |  | nvarchar | 50 |
OPERTIME | 被删除的时间 |  |  | datetime |  |
LINKURL | 链接地址 |  |  | nvarchar | 200 | 链接型栏目有效
CONTENTADDEDITPAGE | 自定义编辑页面 |  |  | nvarchar | 200 |
CONTENTLISTPAGE | 自定义内容(文档)列表页面 |  |  | nvarchar | 200 |
CONTENTSHOWPAGE | 自定义内容查看页面 |  |  | nvarchar | 200 |
OUTLINEFILEDS | --列说明-- |  |  | nvarchar | 1000 |
OUTLINEDBFIELDS | --列说明-- |  |  | nvarchar | 1000 |

备注

  1. 名称：栏目名称在同一个站点下唯一
  2. 属性：是否允许发布,管理节点等属性
  3. 父编号：站点一级子栏目父编号为0
  4. 计划发布：计划任务
  5. 存放位置：见发布设置WCMFOLDERPUBLISHCONFIG.DATAPATH
  6. 状态：共三个有效值[正常=0,已删除=-1,父对象已删除=-2]


WCMCHANNELCHILDINDEXQUOTE

WCMCHANNELCHILDINDEXQUOTE表：

描述：

栏目引用关联信息：触发发布内容

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPLATEID | 模板编号 |  |  | int |  | WCMTEMPLATE.TEMPID
FOLDERTYPE | 文件夹类型 |  |  | int |  |
FOLDERID | 文件夹编号 |  |  | int |  |
QUOTECHANNELID | 被引用的栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID

备注

  1. FOLDERTYPE,FOLDERID共同确定是哪个对象引用了相应的栏目
  2. QUOTECHANNELID确定的栏目发布时触发其它栏目的发布


WCMCHANNELCONTENTLINK

WCMCHANNELCONTENTLINK表：

描述：

栏目热词信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
LINKID | 编号 |  |  | int |  |
LINKNAME | 名称 |  |  | nvarchar | 100 |
LINKURL | 链接地址 |  |  | nvarchar | 100 |
LINKTITLE | 链接的TITLE属性 |  |  | nvarchar | 200 |
CHANNELID | 所属栏目 |  |  | int |  | WCMCHANNEL.CHANNELID
LINKORDER | 序号 |  |  | int |  |
SYSCONTENTLINKID | 系统热词编号 | 0 |  | int |  | WCMCONTENTLINK.LINKID


WCMCHANNELSYN

WCMCHANNELSYN表：

描述：

存储频道的同步分发信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CHANNELSYNID | 编号 |  |  | int |  |
SRCCHANNEL | 源栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
TOCHANNEL | 目标栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
WHERESQL | 检索条件 |  |  | nvarchar | 500 |
SDATE | 分发有效时间(开始) |  |  | datetime |  |
EDATE | 分发有效时间(结束) |  |  | datetime |  |
DOCSDATE | 允许分发的文档创建时间(开始) |  |  | datetime |  |
DOCEDATE | 允许分发的文档创建时间(结束) |  |  | datetime |  |
STATUSES | 允许分发的文档状态 |  |  | nvarchar | 300 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |

备注

  1. SDATE,ENDATE:分发在这个时间区间有效
  2. DOCSDATE,DOCEDATE:只有在这个时间区间内创建的文档才会分发


WCMCHNLDOC

WCMCHNLDOC表：

描述：

栏目和文档之间的关联信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | 编号 |  |  | int |  |
CHNLID | 栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
DOCID | 文档编号 |  |  | int |  | WCMDOCUMENT.DOCID
DOCORDER | 序号 | 0 |  | int |  |
DOCSTATUS | 文档状态 | 0 |  | int |  |
CRUSER | 对象创建者 | 'admin' |  | nvarchar | 100 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
DOCPUBTIME | 文档发布时间 |  |  | datetime |  |
DOCPUBURL | 文档发布后的链接地址 |  |  | nvarchar | 300 |
DOCORDERPRI | 文档置顶序号 | 0 |  | int |  |
INVALIDTIME | 文档置顶失效时间 |  |  | datetime |  |
OPERUSER | 删除文档的操作用户 |  |  | nvarchar | 50 | WCMUSER.USERNAME
OPERTIME | 文档被删除的时间 |  |  | datetime |  |
MODAL | 引用类型 | 1 |  | int |  | 引用类型
DOCRELTIME | 文档撰写时间 |  |  | datetime |  | WCMDOCUMENT.DOCRELTIME
DOCCHANNEL | 所属栏目 |  |  | int |  | WCMDOCUMENT.DOCCHANNEL
DOCFLAG | 标记 |  |  | int |  | WCMDOCUMENT.DOCFLAG
DOCKIND | 分类编号 | 0 |  | int |  | WCMDOCUMENT.DOCKIND

  1. 类型：三个有效值[实体=1,链接引用=2,镜像引用=3]


WCMCHNLEXTFIELD

WCMCHNLEXTFIELD表：

描述：

栏目与扩展字段的关联信息(保留,现在使用 WCMCONTENTEXTFIELD表)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CHANNELID | 栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
EXTFIELDID | 扩展字段编号 |  |  | int |  | WCMEXTFIELD.EXTFIELDID
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMCHNLFLOW

WCMCHNLFLOW表：

描述：

栏目与工作流关联关系(保留,见 WCMFLOWEMPLOY表)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CHNLID | --列说明-- |  |  | int |  |
FLOWID | --列说明-- |  |  | int |  |
ISDEFAULT | --列说明-- |  |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMCHNLTEMP

WCMCHNLTEMP表：

描述：

栏目与模板关联关系(保留 ,见 WCMTEMPLATEEMPLOY表)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CHNLID | --列说明-- |  |  | int |  |
TEMPID | --列说明-- |  |  | int |  |
TEMPTYPE | --列说明-- |  |  | int |  |
ISDEFTEMP | --列说明-- | 0 |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMCONDITIONBEAN

WCMCONDITIONBEAN表：

描述：

条件工件流驱动(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONDITIONBEANID | --列说明-- |  |  | int |  |
BEANNAME | --列说明-- |  |  | nvarchar | 50 |
BEANPATH | --列说明-- |  |  | nvarchar | 60 |
CONDITIONDESC | --列说明-- |  |  | nvarchar | 200 |
PARAMETERS | --列说明-- |  |  | nvarchar | 1000 |
CONDITYPE | --列说明-- | 0 |  | int |  |
SETURL | --列说明-- |  |  | nvarchar | 100 |


WCMCONFIG

WCMCONFIG表：

描述：

系统配置

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONFIGID | 编号 |  |  | int |  |
CTYPE | 类型 | 0 |  | smallint |  |
CKEY | 属性名(键) |  |  | nvarchar | 50 |
CVALUE | 属性值(值) |  |  | nvarchar | 500 |
CDESC | 该项目配置的说明性描述 |  |  | nvarchar | 100 |
ENCRYPTED | 属性值是否加密存储 | 0 |  | int |  |
SITEID | 所属于站点编号 | 0 |  | int |  | 保留


WCMCONTACT

WCMCONTACT表：

描述：

统用户的联系人信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONTACTID | 编号 |  |  | int |  |
NICKNAME | 联系人昵称 |  |  | nvarchar | 50 |
CDESC | 说明描述 |  |  | nvarchar | 200 |
ADDRESS | 联系地址 |  |  | nvarchar | 100 |
EMAIL | 联系人电子邮件 |  |  | nvarchar | 200 |
TEL | 联系电话 |  |  | nvarchar | 50 |
MOBILE | 移动联系电话 |  |  | nvarchar | 50 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
USERNAME | 联系人名称 |  |  | nvarchar | 100 |


WCMCONTENTEXTFIELD

WCMCONTENTEXTFIELD表：

描述：

扩展字段使用关联信息
表示扩展字段被哪个栏目/站点使用

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONTENTEXTFIELDID | 编号 |  |  | int |  |
OBJID | 对象编号 |  |  | int |  |
OBJTYPE | 对象类型 |  |  | int |  |
EXTFIELDID | 扩展字段编号 |  |  | int |  | WCMEXTFIELD.EXTFIELDID
LOGICFIELDDESC | 字段逻辑显示名称 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |

备注

  1. OBJID,OBJTYPE共同确定字段与哪个对象关联
    对于类型,一般是三个有效值[栏目=101,站点=103,站点根=0]


WCMCONTENTLINK

WCMCONTENTLINK表：

描述：

系统热词

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONTENTLINKID | 编号 |  |  | int |  |
SITEID | 热词所属站点编号 |  |  | int |  | 保留
LINKNAME | 名称 |  |  | nvarchar | 100 |
LINKURL | 热词所代表的链接地址 |  |  | nvarchar | 100 |
LINKTITLE | 链接地址的title属性说明 |  |  | nvarchar | 200 |
CONTENTLINKTYPE | 所属分类编号 |  |  | int |  | WCMCONTENTLINKTYPE.CONTENTLINKTYPEID


WCMCONTENTLINKTYPE

WCMCONTENTLINKTYPE表：

描述：

系统热词分类

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONTENTLINKTYPEID | 编号 |  |  | int |  |
TYPENAME | 分类名 |  |  | nvarchar | 100 |
TYPEDESC | 分类描述说明 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 70 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMCONTGROUP

WCMCONTGROUP表：

描述：

系统联系人组信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
GROUPID | 编号 |  |  | int |  |
GNAME | 名称 |  |  | nvarchar | 200 |
GDESC | 说明性描述 |  |  | nvarchar | 200 |
EMAIL | 电子邮件地址 |  |  | nvarchar | 200 |
PARENTID | 父组编号 |  |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMCONTGRPMAP

WCMCONTGRPMAP表：

描述：

联系人和联系人组之间的关联

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONTGRPID | 联系人组编号 |  |  | int |  | WCMCONTGROUP.GROUPID
CONTACTID | 联系人编号 |  |  | int |  | WCMCONTACT.CONTRACTID
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMDBUPDATE

WCMDBUPDATE表：

描述：

WCM系统数据库更新记录表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
UPDVERSION | 更新版本 |  |  | int |  |
UPDINFO | 更新信息说明 |  |  | nvarchar | 2000 |
UPDUSER | 更新者 |  |  | char | 10 |
UPDTIME | 更新时间 |  |  | datetime |  |


WCMDBUPDATELOG

WCMDBUPDATELOG表：

描述：

WCM系统数据库更新日志记录(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DBUPDATELOGID | 编号 |  |  | int |  |
LOGTITLE | 日志标题 |  |  | nvarchar | 100 |
LOGMEMO | 更新详细说明 |  |  | nvarchar | 2000 |
SUBMITOR | 提交者 |  |  | nvarchar | 50 |
TABLENAME | 更新修改的系统表名 |  |  | nvarchar | 50 |
LOGTYPE | 类型 |  |  | int |  |
SQLSERVER | MS SQLServer的脚本 |  |  | ntext |  |
ORACLESQL | Oracle的脚本 |  |  | ntext |  |
DB2SQL | DB2的脚本 |  |  | ntext |  |
SYSBASESQL | Sybase的脚本 |  |  | ntext |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMDOCBAK

WCMDOCBAK表：

描述：

文档的备份,各版本的内容(保留,见 WCMDOCUMENT 表)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCBAKID | 编号 |  |  | int |  |
DOCID | 文档编号 |  |  | int |  | WCMDOCUMENT.DOCID
DOCCHANNEL | --列说明-- |  |  | int |  |
DOCVERSION | --列说明-- | 0 |  | int |  |
DOCTYPE | --列说明-- |  |  | int |  |
DOCTITLE | --列说明-- |  |  | nvarchar | 1000 |
DOCSOURCE | --列说明-- |  |  | int |  |
DOCSECURITY | --列说明-- |  |  | int |  |
DOCSTATUS | --列说明-- |  |  | int |  |
DOCKIND | --列说明-- |  |  | int |  |
DOCCONTENT | --列说明-- |  |  | ntext |  |
DOCHTMLCON | --列说明-- |  |  | ntext |  |
DOCABSTRACT | --列说明-- |  |  | nvarchar | 2000 |
DOCKEYWORDS | --列说明-- |  |  | nvarchar | 200 |
DOCRELWORDS | --列说明-- |  |  | nvarchar | 200 |
DOCPEOPLE | --列说明-- |  |  | nvarchar | 200 |
DOCPLACE | --列说明-- |  |  | nvarchar | 200 |
DOCAUTHOR | --列说明-- |  |  | nvarchar | 200 |
DOCEDITOR | --列说明-- |  |  | nvarchar | 50 |
DOCAUDITOR | --列说明-- |  |  | nvarchar | 50 |
DOCOUTUPID | --列说明-- |  |  | int |  |
DOCVALID | --列说明-- |  |  | datetime |  |
DOCPUBURL | --列说明-- |  |  | nvarchar | 400 |
DOCPUBTIME | --列说明-- |  |  | datetime |  |
DOCRELTIME | --列说明-- |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
BAKUSER | --列说明-- |  |  | nvarchar | 50 |
BAKTIME | --列说明-- |  |  | datetime |  |
DOCWORDSCOUNT | --列说明-- | 0 |  | int |  |
DOCPRO | --列说明-- | 1 |  | smallint |  |
RIGHTDEFINED | --列说明-- | 0 |  | int |  |
TITLECOLOR | --列说明-- |  |  | varchar | 20 |
TEMPLATEID | --列说明-- |  |  | int |  |
SCHEDULE | --列说明-- | 0 |  | int |  |
DOCNO | --列说明-- |  |  | nvarchar | 4000 |
DOCFLAG | --列说明-- | 0 |  | int |  |
EDITOR | --列说明-- |  |  | nvarchar | 100 |
HITSCOUNT | --列说明-- | 0 |  | int |  |
DOCPUBHTMLCON | --列说明-- |  |  | ntext |  |
SUBDOCTITLE | --列说明-- |  |  | nvarchar | 500 |
ATTACHPIC | --列说明-- |  |  | smallint |  |
DOCLINK | --列说明-- |  |  | nvarchar | 100 |
DOCFILENAME | --列说明-- |  |  | nvarchar | 50 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
OPERTIME | --列说明-- |  |  | datetime |  |
OPERUSER | --列说明-- |  |  | nvarchar | 50 |
DOCSOURCENAME | --列说明-- |  |  | nvarchar | 100 |
RANDOMSERIAL | --列说明-- |  |  | nvarchar | 100 |


WCMDOCKEYWORD

WCMDOCKEYWORD表：

描述：

文档关键词

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCID | 文档编号 |  |  | int |  | 标示关键词属于哪个文档
DOCKEYWORD | 关键词 |  |  | nvarchar | 200 |
DOCKEYWORDORDER | 序号 |  |  | smallint |  |
DOCCRTIME | 文档创建时间 |  |  | datetime |  |
SITEID | 文档所属站点编号 |  |  | int |  |


WCMDOCKIND

WCMDOCKIND表：

描述：

文档的分类信息(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCKINDID | 编号 |  |  | int |  |
PARENTID | 父分类编号 | 0 |  | int |  |
GRADE | 级别 | 0 |  | tinyint |  |
CODE | 分类编码 |  |  | nvarchar | 200 |
DOCKINDNAME | 分类名称 |  |  | nvarchar | 200 |
DOCKINDDESC | 分类描述 |  |  | nvarchar | 200 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMDOCQUOTEIMAGE

WCMDOCQUOTEIMAGE表：

描述：

引用图片库图片的文档记录

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCID | 文档编号 |  |  | int |  | WCMDOCUMENT.DOCID
QUOTEIMAGEID | 图片库图片编号 |  |  | int |  |

备注

  1. 在正文中插入引用了图片库图片的文档记录,在使用图片库选件是有效


WCMDOCREPLY

WCMDOCREPLY表：

描述：

文档回复 (保留,在EKP等动态应用使用)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCREPLYID | 编号 |  |  | int |  |
REDOCID | 回复的文档编号 |  |  | int |  |
RETITLE | 标题 |  |  | nvarchar | 200 |
RECONTENT | 内容 |  |  | nvarchar | 200 |
REDESC | 说明 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
REPLYTYPE | 类型 | 0 |  | int |  |


WCMDOCSOURCE_STAT_NEW

WCMDOCSOURCE_STAT_NEW表：

描述：

文档来源统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
SOURCEID | --列说明-- |  |  | int |  |
DOCSOURCENAME | --列说明-- |  |  | nvarchar | 200 |
ALLDOCCOUNT | --列说明-- |  |  | int |  |
ALLWORDSCOUNT | --列说明-- |  |  | int |  |
PUBDOCCOUNT | --列说明-- |  |  | int |  |
PUBWORDSCOUNT | --列说明-- |  |  | int |  |


WCMDOCSYN

WCMDOCSYN表：

描述：

同步分发已分发文档记录

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCSYNID | 编号 |  |  | int |  |
CHNLID | 栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
DOCID | 文档编号 |  |  | int |  | WCMDOCUMENT.DOCID

备注

  1. 栏目编号是分发目标栏目编号,见 WCMCHANNELSYN.TOCHANNEL


WCMDOCTYPE

WCMDOCTYPE表：

描述：

文档的类型信息(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCTYPEID | 编号 |  |  | int |  |
TYPENAME | 名称 |  |  | nvarchar | 50 |
TYPEDESC | 说明 |  |  | nvarchar | 200 |
TYPEEXT | 扩展名 |  |  | nvarchar | 50 |
TYPEFORM | 格式 |  |  | nvarchar | 200 |
TYPETAG | 表现形式 |  |  | nvarchar | 1000 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
TYPEOPENWITH | 打开方式 |  |  | nvarchar | 100 |


WCMDOCUMENT

WCMDOCUMENT表：

描述：

文档信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCID | 编号 |  |  | int |  |
DOCCHANNEL | 所属栏目 |  |  | int |  |
DOCVERSION | 版本号 | 0 |  | int |  |
DOCTYPE | 类型 |  |  | int |  | 类型
DOCTITLE | 文档标题 |  |  | nvarchar | 1000 |
DOCSOURCE | 文档来源 | 0 |  | int |  | WCMSOURCE.SOURCEID
DOCSECURITY | 安全级别 |  |  | int |  | WCMSECURITY.SECURITYID
DOCSTATUS | 文档状态 |  |  | int |  | WCMSTATUS.STATUSID
DOCKIND | 文档分类 |  |  | int |  | 分类
DOCCONTENT | 纯文本内容 |  |  | ntext |  |
DOCHTMLCON | HTML文本内容 |  |  | ntext |  |
DOCABSTRACT | 内容摘要 |  |  | nvarchar | 2000 |
DOCKEYWORDS | 关键词 |  |  | nvarchar | 200 |
DOCRELWORDS | 相关词 |  |  | nvarchar | 200 | 相关词
DOCPEOPLE | 涉及的人物 |  |  | nvarchar | 200 | 首页标题
DOCPLACE | 涉及的地址 |  |  | nvarchar | 200 |
DOCAUTHOR | 作者 |  |  | nvarchar | 200 |
DOCEDITOR | 编辑 |  |  | nvarchar | 50 |
DOCAUDITOR | 编审 |  |  | nvarchar | 50 |
DOCOUTUPID | 输入编号 |  |  | int |  | 输入编号
DOCVALID | 有效时间 |  |  | datetime |  |
DOCPUBURL | 发布后的链接地址 |  |  | nvarchar | 400 |
DOCPUBTIME | 发布时间 |  |  | datetime |  |
DOCRELTIME | 撰写时间 |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
DOCWORDSCOUNT | 纯文本内容单词数 | 0 |  | int |  |
DOCPRO | 文档属性 | 1 |  | int |  |
RIGHTDEFINED | 独立的权限设置 | 0 |  | smallint |  |
TITLECOLOR | 标题的颜色 |  |  | varchar | 20 |
TEMPLATEID | 设置的模板编号 | 0 |  | int |  |
SCHEDULE | 计划任务编号 | 0 |  | int |  |
DOCNO | 其它编号 |  |  | nvarchar | 4000 | 其它编号
DOCFLAG | 标记 | 0 |  | int |  | 标记
EDITOR | 文档编辑器 |  |  | nvarchar | 100 | 保留
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
HITSCOUNT | 点击数 | 0 |  | int |  |
DOCPUBHTMLCON | 发布HTML内容 |  |  | ntext |  |
SUBDOCTITLE | 副标题 |  |  | nvarchar | 500 |
ATTACHPIC | 是否附图 |  |  | smallint |  |
DOCLINK | 链接地址 |  |  | nvarchar | 100 | 链接地址
DOCFILENAME | 外部文件名 |  |  | nvarchar | 50 |
DOCFROMVERSION | 从哪个版本恢复 |  |  | int |  |
OPERTIME | 删除时间 |  |  | datetime |  |
OPERUSER | 删除操作用户 |  |  | nvarchar | 50 |
FLOWOPERATIONMARK | --列说明-- |  |  | nvarchar | 200 |
FLOWPREOPERATIONMARK | --列说明-- |  |  | nvarchar | 200 |
FLOWOPERATIONMASKENUM | --列说明-- |  |  | nvarchar | 2000 |
DOCSOURCENAME | 文档来源名称 |  |  | nvarchar | 100 |
DOCLINKTO | --列说明-- |  |  | nvarchar | 300 |
DOCMIRRORTO | --列说明-- |  |  | nvarchar | 300 |
RANDOMSERIAL | 表单文档随机查询号 |  |  | nvarchar | 100 |
POSTUSER | 表单文档提交用户 |  |  | varchar | 50 |

备注

  1. 类型：四个有效值[文本文档=10,HTML文档=20,链接文档=30,外部文件文档=40]
  2. 分类：在元数据选件中,该列值是所属视图编号
  3. 首页标题：普通文档用作首页标题,在图片库是图片涉及的相关人物
  4. 输入编号：一般可用于数据交换,记录外部的唯一编号
  5. 其它编号：在表单选件中,记录表单文档的唯一编号(如果有的话);场景式服务亦有用
  6. 标记：在表单选件中,记录的是所属栏目的表单编号(WCMINFOVIEW.INFOVIEWID)
  7. 在图片库中,记录各缩放图的文件名


WCMEVENT

WCMEVENT表：

描述：

系统的日程表事件

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
EVENTID | 编号 |  |  | int |  |
OWNER | 操作所有者 |  |  | nvarchar | 50 |
TITLE | 事件标题 |  |  | nvarchar | 50 |
EDESC | 事件说明 |  |  | nvarchar | 500 |
ETYPE | 类型 |  |  | smallint |  | WCMEVENTTYPE.EVENTTYPEID
ESTART | 开始时间 |  |  | datetime |  |
EEND | 结束时间 |  |  | datetime |  |
EMAIL | 电子邮件地址 |  |  | nvarchar | 1000 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
ISSHARE | 是否共享 |  |  | smallint |  |
ONLINEREMIND | 是否在线短消息提醒 |  |  | smallint |  |
EMAILREMIND | 是否邮件提醒 |  |  | smallint |  |
MOBILEREMIND | 是否手机短信提醒 |  |  | smallint |  |
AHEADREMDTIME | 距离开始多少时间提醒 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
REMINDMSGID | 提醒消息编号 | 0 |  | int |  |


WCMEVENTSHARE

WCMEVENTSHARE表：

描述：

事件共享信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
EVENTSHAREID | 编号 |  |  | int |  |
EVENTID | 共享的事件编号 |  |  | int |  | WCMEVENT.EVENTID
OBJID | 共享该事件的对象编号 |  |  | int |  |
OBJTYPE | 共享该事件的对象编号 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME

备注

  1. OBJID,OBJTYPE共同确定共享该事件的对象,可以共享事件的包括用户、用户组、角色等对象


WCMEVENTTYPE

WCMEVENTTYPE表：

描述：

事件类型信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
EVENTTYPEID | 编号 |  |  | int |  |
TYPENAME | 名称 |  |  | nvarchar | 50 |
TYPEDESC | 说明 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMEXCELDATA

WCMEXCELDATA表：

描述：

自定义表单数据(保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
DOCCHANNEL | --列说明-- |  |  | int |  |
FORMID | --列说明-- |  |  | int |  |
STR1 | --列说明-- |  |  | nvarchar | 500 |
STR2 | --列说明-- |  |  | nvarchar | 500 |
STR3 | --列说明-- |  |  | nvarchar | 500 |
STR4 | --列说明-- |  |  | nvarchar | 500 |
STR5 | --列说明-- |  |  | nvarchar | 500 |
STR6 | --列说明-- |  |  | nvarchar | 500 |
STR7 | --列说明-- |  |  | nvarchar | 500 |
STR8 | --列说明-- |  |  | nvarchar | 500 |
STR9 | --列说明-- |  |  | nvarchar | 500 |
STR10 | --列说明-- |  |  | nvarchar | 500 |
STR11 | --列说明-- |  |  | nvarchar | 500 |
STR12 | --列说明-- |  |  | nvarchar | 500 |
STR13 | --列说明-- |  |  | nvarchar | 500 |
STR14 | --列说明-- |  |  | nvarchar | 500 |
STR15 | --列说明-- |  |  | nvarchar | 500 |
STR16 | --列说明-- |  |  | nvarchar | 500 |
STR17 | --列说明-- |  |  | nvarchar | 500 |
STR18 | --列说明-- |  |  | nvarchar | 500 |
STR19 | --列说明-- |  |  | nvarchar | 500 |
STR20 | --列说明-- |  |  | nvarchar | 500 |
STR21 | --列说明-- |  |  | nvarchar | 500 |
STR22 | --列说明-- |  |  | nvarchar | 500 |
STR23 | --列说明-- |  |  | nvarchar | 500 |
STR24 | --列说明-- |  |  | nvarchar | 500 |
STR25 | --列说明-- |  |  | nvarchar | 500 |
STR26 | --列说明-- |  |  | nvarchar | 500 |
STR27 | --列说明-- |  |  | nvarchar | 500 |
STR28 | --列说明-- |  |  | nvarchar | 500 |
STR29 | --列说明-- |  |  | nvarchar | 500 |
STR30 | --列说明-- |  |  | nvarchar | 500 |
STR31 | --列说明-- |  |  | nvarchar | 500 |
STR32 | --列说明-- |  |  | nvarchar | 500 |
STR33 | --列说明-- |  |  | nvarchar | 500 |
STR34 | --列说明-- |  |  | nvarchar | 500 |
STR35 | --列说明-- |  |  | nvarchar | 500 |
STR36 | --列说明-- |  |  | nvarchar | 500 |
STR37 | --列说明-- |  |  | nvarchar | 500 |
STR38 | --列说明-- |  |  | nvarchar | 500 |
STR39 | --列说明-- |  |  | nvarchar | 500 |
STR40 | --列说明-- |  |  | nvarchar | 500 |
STR41 | --列说明-- |  |  | nvarchar | 500 |
STR42 | --列说明-- |  |  | nvarchar | 500 |
STR43 | --列说明-- |  |  | nvarchar | 500 |
STR44 | --列说明-- |  |  | nvarchar | 500 |
STR45 | --列说明-- |  |  | nvarchar | 500 |
STR46 | --列说明-- |  |  | nvarchar | 500 |
STR47 | --列说明-- |  |  | nvarchar | 500 |
STR48 | --列说明-- |  |  | nvarchar | 500 |
STR49 | --列说明-- |  |  | nvarchar | 500 |
STR50 | --列说明-- |  |  | nvarchar | 500 |
NUM1 | --列说明-- |  |  | int |  |
NUM2 | --列说明-- |  |  | int |  |
NUM3 | --列说明-- |  |  | int |  |
NUM4 | --列说明-- |  |  | int |  |
NUM5 | --列说明-- |  |  | int |  |
NUM6 | --列说明-- |  |  | int |  |
NUM7 | --列说明-- |  |  | int |  |
NUM8 | --列说明-- |  |  | int |  |
NUM9 | --列说明-- |  |  | int |  |
NUM10 | --列说明-- |  |  | int |  |
NUM11 | --列说明-- |  |  | int |  |
NUM12 | --列说明-- |  |  | int |  |
NUM13 | --列说明-- |  |  | int |  |
NUM14 | --列说明-- |  |  | int |  |
NUM15 | --列说明-- |  |  | int |  |
NUM16 | --列说明-- |  |  | int |  |
NUM17 | --列说明-- |  |  | int |  |
NUM18 | --列说明-- |  |  | int |  |
NUM19 | --列说明-- |  |  | int |  |
NUM20 | --列说明-- |  |  | int |  |
FNUM1 | --列说明-- |  |  | float |  |
FNUM2 | --列说明-- |  |  | float |  |
FNUM3 | --列说明-- |  |  | float |  |
FNUM4 | --列说明-- |  |  | float |  |
FNUM5 | --列说明-- |  |  | float |  |
FNUM6 | --列说明-- |  |  | float |  |
FNUM7 | --列说明-- |  |  | float |  |
FNUM8 | --列说明-- |  |  | float |  |
FNUM9 | --列说明-- |  |  | float |  |
FNUM10 | --列说明-- |  |  | float |  |
FNUM11 | --列说明-- |  |  | float |  |
FNUM12 | --列说明-- |  |  | float |  |
FNUM13 | --列说明-- |  |  | float |  |
FNUM14 | --列说明-- |  |  | float |  |
FNUM15 | --列说明-- |  |  | float |  |
FNUM16 | --列说明-- |  |  | float |  |
FNUM17 | --列说明-- |  |  | float |  |
FNUM18 | --列说明-- |  |  | float |  |
FNUM19 | --列说明-- |  |  | float |  |
FNUM20 | --列说明-- |  |  | float |  |
TEXTCONTENT1 | --列说明-- |  |  | ntext |  |
TEXTCONTENT2 | --列说明-- |  |  | ntext |  |
TEXTCONTENT3 | --列说明-- |  |  | ntext |  |
TEXTCONTENT4 | --列说明-- |  |  | ntext |  |
TEXTCONTENT5 | --列说明-- |  |  | ntext |  |
DOCID | --列说明-- | 0 |  | int |  |
DOCORDER | --列说明-- | 0 |  | int |  |
DOCSTATUS | --列说明-- | 1 |  | int |  |
DOCPUBURL | --列说明-- |  |  | nvarchar | 400 |
DOCPUBTIME | --列说明-- |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
DOCPUBHTMLCON | --列说明-- |  |  | ntext |  |
DOCOUTUPID | --列说明-- | 0 |  | int |  |
DOCVERSION | --列说明-- | 0 |  | int |  |
DOCSECURITY | --列说明-- | 0 |  | int |  |
DOCSOURCE | --列说明-- | 0 |  | int |  |
DOCCONTENT | --列说明-- |  |  | ntext |  |
DOCTYPE | --列说明-- | 0 |  | int |  |
DOCTITLE | --列说明-- |  |  | nvarchar | 250 |
DATE1 | --列说明-- |  |  | datetime |  |
DATE2 | --列说明-- |  |  | datetime |  |
DATE3 | --列说明-- |  |  | datetime |  |
DATE4 | --列说明-- |  |  | datetime |  |
DATE5 | --列说明-- |  |  | datetime |  |
DATE6 | --列说明-- |  |  | datetime |  |
DATE7 | --列说明-- |  |  | datetime |  |
DATE8 | --列说明-- |  |  | datetime |  |
DATE9 | --列说明-- |  |  | datetime |  |
DATE10 | --列说明-- |  |  | datetime |  |


WCMEXPIRATION

WCMEXPIRATION表：

描述：

文档的过期处理方式(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
EXPID | 编号 |  |  | int |  |
DOCID | 文档编号 |  |  | int |  |
OPTYPE | 执行的操作编号 |  |  | int |  |
OPARGS | 操作类型参数 |  |  | nvarchar | 1000 |
SERN | 序号 |  |  | int |  |
RESULT | 结果 |  |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMEXTFIELD

WCMEXTFIELD表：

描述：

系统扩展字段

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
EXTFIELDID | 编号 |  |  | int |  |
TABLENAME | 扩展字段所属表名 |  |  | nvarchar | 50 | 表名
FIELDNAME | 名称 |  |  | nvarchar | 50 |
FIELDTYPE | 类型 |  |  | nvarchar | 10 |
FIELDMAXLEN | 最大长度 |  |  | int |  |
FIELDNULLABLE | 是否允许空值 | 1 |  | smallint |  |
FIELDDEFAULT | 默认值 |  |  | nvarchar | 50 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
FIELDSCALE | 精度 | 0 |  | int |  |

备注

  1. 表名：默认扩展字段只作用于WCMDOCUMENT表.每个记录记录两次,另一条记录对应于WCMDOCBAK表


WCMFILETYPE

WCMFILETYPE表：

描述：

文档附件的类型信息(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FILETYPEID | 编号 |  |  | int |  |
TYPENAME | 名称 |  |  | nvarchar | 50 |
TYPEDESC | 说明 |  |  | nvarchar | 200 |
TYPEEXT | 扩展名 |  |  | nvarchar | 50 |
TYPEFORM | 格式 |  |  | nvarchar | 200 |
TYPETAG | 表现形式 |  |  | nvarchar | 1000 |
TYPEOPENWITH | 打开方式 |  |  | nvarchar | 100 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMFLOW

WCMFLOW表：

描述：

工作流信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWID | 编号 |  |  | int |  |
FLOWNAME | 名称 |  |  | nvarchar | 50 |
FLOWDESC | 描述 |  |  | nvarchar | 200 |
SNAME | 起始节点名 |  |  | nvarchar | 100 |
ENAME | 结束节点名 |  |  | nvarchar | 100 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
SITEID | 所属站点编号 |  |  | int |  | WCMWEBSITE.SITEID
OWNERTYPE | 所属对象类型 |  |  | int |  |
OWNERID | 所属对象编号 |  |  | int |  |
INFOVIEWID | 关联表单编号 |  |  | int |  | WCMINFOVIEW.INFOVIEWID
OPERATIONMARKENUM | 工作流文档操作标签枚举值 |  |  | nvarchar | 2000 | WCMDOCUMENT.OPERATIONMARKENUM

备注

  1. OWNERTYPE,OWNERID共同确定工作所属对象(站点/栏目等),SITEID为保留字段
  2. 表单关联编号在使用表是选件时有效


WCMFLOWACTION

WCMFLOWACTION表：

描述：

工作流操作的基本信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ACTIONID | 编号 |  |  | int |  |
NODEID | 所属节点编号 |  |  | int |  | WCMFLOWNODE.NODEID
ACTIONNAME | 名称 |  |  | nvarchar | 50 |
ACTIONDESC | 说明 |  |  | nvarchar | 200 |
OPTYPE | 类型编号 |  |  | int |  | WCMOPER.OPERID
OPARGS | 操作参数 |  |  | nvarchar | 1000 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMFLOWBRANCH

WCMFLOWBRANCH表：

描述：

工作流连线(分支)的基本信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
BRANCHID | 编号 |  |  | int |  |
NODEID | 所属节点编号 |  |  | int |  | WCMFLOWNODE.NODEID
NEXTNAME | 下一节点名称 |  |  | nvarchar | 50 |
STATUS | 状态 |  |  | int |  |
NOTIFY | 通知方式 |  |  | int |  |
CRTIME | 对象创建时间 |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
BNAME | 分支描述/名称 | '移交下一个节点' |  | nvarchar | 200 |
OPERATIONMARK | 操作标签 |  |  | nvarchar | 200 |
OPERATIONMARKENABLE | 操作标签是否有效 |  |  | smallint |  |


WCMFLOWCONTENTCONFIG

WCMFLOWCONTENTCONFIG表：

描述：

可流转内容对象配置

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWCONTENTCONFIGID | 编号 |  |  | int |  |
OBJTYPE | 对象类型 |  |  | int |  |
OBJCLASS | 对象所属类(java实现) |  |  | nvarchar | 200 |
OBJDESC | 说明 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMFLOWDOC

WCMFLOWDOC表：

描述：

工作流和文档的关联信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWDOCID | 编号 |  |  | int |  |
NODEID | 文档所处节点编号 |  |  | int |  | WCMFLOWNODE.NODEID
PRENODEID | 文档所处的前一节点编号 |  |  | int |  | WCMFLOWNODE.NODEID
POSTUSER | 文档提交用户 |  |  | nvarchar | 50 |
POSTTIME | 文档提文时间 |  |  | datetime |  |
POSTDESC | 文档提交说明 |  |  | nvarchar | 500 |
TOUSERS | 文档提交的目标用户 |  |  | nvarchar | 300 |
CRTIME | 对象创建时间 |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
FLAG | 流转标记 | 0 |  | smallint |  |
OBJTYPE | 流转对象类型 |  |  | int |  |
OBJID | 流转对象编号 |  |  | int |  |
TOUSERID | --列说明-- | 0 |  | int |  |
RECEIVETIME | 到达时间 |  |  | datetime |  |
ACCEPTTIME | 签收时间 |  |  | datetime |  |
ACCEPTED | 是否已签收 | 0 |  | smallint |  |
WORKED | 是否已处理 | 0 |  | smallint |  |
PARENTID | 父编号 | 0 |  | int |  |
WORKMODAL | 处理模式 | 0 |  | smallint |  |
TOGETHERUSERS | 会签用户集合 |  |  | nvarchar | 200 |
WORKTIME | 处理时间 |  |  | datetime |  |
PREFLOWDOCID | 前一流转编号 | 0 |  | int |  |
SERIALNUM | 序列号 | 0 |  | bigint |  |
BRANCHSERIALNUM | 分支序列号 | 0 |  | bigint |  |


WCMFLOWDOCBAK

WCMFLOWDOCBAK表：

描述：

文档与工作流的关联关系(流转轨迹)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWDOCID | 编号 |  |  | int |  |
NODEID | 文档所处节点编号 |  |  | int |  | WCMFLOWNODE.NODEID
PRENODEID | 文档所处的前一节点编号 |  |  | int |  | WCMFLOWNODE.NODEID
POSTUSER | 文档提交用户 |  |  | nvarchar | 50 |
POSTTIME | 文档提文时间 |  |  | datetime |  |
POSTDESC | 文档提交说明 |  |  | nvarchar | 500 |
TOUSERS | 文档提交的目标用户 |  |  | nvarchar | 300 |
CRTIME | 对象创建时间 |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
FLAG | --列说明-- | 0 |  | smallint |  |
OBJTYPE | --列说明-- |  |  | int |  |
OBJID | --列说明-- |  |  | int |  |


WCMFLOWEMPLOY

WCMFLOWEMPLOY表：

描述：

使用工作流的对象

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWEMPLOYID | 编号 |  |  | int |  |
EMPLOYERTYPE | 对象类型 |  |  | int |  |
EMPLOYERID | 对象编号 |  |  | int |  |
FLOWID | 工作流对象编号 |  |  | int |  | WCMFLOW.FLOWID

备注

  1. EMPLOYERTYPE,EMPLOYERID共同确定是哪个对象使用了工作流,一般只有栏目对象


WCMFLOWEVENTCONDITION

WCMFLOWEVENTCONDITION表：

描述：

保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWEVENTCONDITIONID | --列说明-- |  |  | int |  |
FLOWNODEEVENTID | --列说明-- |  |  | int |  |
CONDITIONNAME | --列说明-- |  |  | nvarchar | 100 |
RECORDER | --列说明-- |  |  | int |  |
CONDITIONTYPE | --列说明-- |  |  | int |  |
PARAMETER | --列说明-- |  |  | nvarchar | 500 |
CONDITIONBEANID | --列说明-- | 0 |  | int |  |


WCMFLOWEVENTOPERATE

WCMFLOWEVENTOPERATE表：

描述：

保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWEVENTOPERATEID | --列说明-- |  |  | int |  |
FLOWNODEEVENTID | --列说明-- |  |  | int |  |
OPERATENNAME | --列说明-- |  |  | nvarchar | 100 |
RECORDER | --列说明-- |  |  | int |  |
OPERATETYPE | --列说明-- |  |  | int |  |
PARAMETER | --列说明-- |  |  | nvarchar | 500 |
OPERATIONBEANID | --列说明-- |  |  | int |  |


WCMFLOWMONOPER

WCMFLOWMONOPER表：

描述：

保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWID | --列说明-- |  |  | int |  |
OPERTYPE | --列说明-- |  |  | int |  |
OPERID | --列说明-- |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMFLOWNODE

WCMFLOWNODE表：

描述：

工件流节点信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
NODEID | 编号 |  |  | int |  |
FLOWID | 所属工作流编号 |  |  | int |  | WCMFLOW.FLOWID
NODENAME | 名称 |  |  | nvarchar | 50 |
NODEDESC | 说明 |  |  | nvarchar | 200 |
CENTERX | 位置X座标 |  |  | int |  |
CENTERY | 位置Y座标 |  |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
ACTIONS | 操作 | 0 |  | int |  |
TOGETHER | 是否会签 | 0 |  | smallint |  |
OUTFLOWID | 外部工作流编号 | 0 |  | int |  |
TOUSERSCREATOR | --列说明-- |  |  | nvarchar | 200 |
WORKMODAL | --列说明-- | 0 |  | int |  |
TOUSERSCREATORPARAMS | --列说明-- |  |  | nvarchar | 200 |


WCMFLOWNODEEVENT

WCMFLOWNODEEVENT表：

描述：

保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWNODEEVENTID | --列说明-- |  |  | int |  |
NODEID | --列说明-- |  |  | int |  |
RECORDER | --列说明-- |  |  | int |  |
EVENTTYPE | --列说明-- | 1 |  | int |  |
EVENTNAME | --列说明-- |  |  | nvarchar | 100 |
CANDOSTATUS | --列说明-- | 1 |  | smallint |  |
BOOLCALCULATION | --列说明-- | 1 |  | smallint |  |
CONTINUEEXCEPTION | --列说明-- | 1 |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMFLOWNODEOPER

WCMFLOWNODEOPER表：

描述：

保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
NODEID | --列说明-- |  |  | int |  |
OPERTYPE | --列说明-- |  |  | int |  |
OPERID | --列说明-- |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMFOLDERPUBLISHCONFIG

WCMFOLDERPUBLISHCONFIG表：

描述：

发布属性配置信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FOLDERPUBLISHCONFIGID | 编号 |  |  | int |  |
FOLDERTYPE | 文件夹类型 |  |  | int |  |
FOLDERID | 文件夹编号 |  |  | int |  |
OUTLINEFILE | 概览文件 |  |  | nvarchar | 100 |
DETAILFILEEXT | 细览扩展名 |  |  | nvarchar | 10 |
DATAPATH | 存放位置 |  |  | nvarchar | 100 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
ROOTDOMAIN | http域 |  |  | nvarchar | 200 |
SITELANGUAGE | 站点语言编号 |  |  | int |  |
PAGEENCODING | 站点页面编码 |  |  | nvarchar | 50 |

备注

  1. FOLDERTYPE,FOLDERID确定是哪个对象的配置,一般是站点和栏目
  2. ROOTDOMAIN只有站点有值


WCMFOLDERPUBLISHINFO

WCMFOLDERPUBLISHINFO表：

描述：

发布属性配置,FACAD对象(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
WCMFOLDERPUBLISHCONFIGID | --列说明-- |  |  | int |  |
FOLDERTYPE | --列说明-- |  |  | int |  |
FOLDERID | --列说明-- |  |  | int |  |
OUTLINEFILENAME | --列说明-- |  |  | nvarchar | 100 |
DETAILFILEEXT | --列说明-- |  |  | nvarchar | 100 |
DATAPATH | --列说明-- |  |  | nvarchar | 100 |
ROOTDOMAIN | --列说明-- |  |  | nvarchar | 200 |
OUTLINETEMPLATEID | --列说明-- |  |  | nvarchar | 50 |
DETAILTEMPLATEID | --列说明-- |  |  | int |  |
STATUSESCANDOPUB | --列说明-- |  |  | nvarchar | 50 |
STATUSIDAFTERMODIFY | --列说明-- |  |  | int |  |
SCHEDULEMODE | --列说明-- |  |  | int |  |
STARTTIME | --列说明-- |  |  | nvarchar | 10 |
ENDTIME | --列说明-- |  |  | nvarchar | 10 |
INTERVAL | --列说明-- |  |  | int |  |
EXECTIME | --列说明-- |  |  | nvarchar | 10 |
DEFINEFILERULE | --列说明-- |  |  | smallint |  |
DEFINESCHEDULE | --列说明-- |  |  | smallint |  |
DEFINESTATUS | --列说明-- |  |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
DEFAULTOUTLINETEMPLATEID | --列说明-- |  |  | int |  |
SITELANGUAGE | --列说明-- |  |  | int |  |
PAGEENCODING | --列说明-- |  |  | nvarchar | 50 |
ISRESETCHILDRENTEMPLATES | --列说明-- | 0 |  | int |  |


WCMFORMFIELDS

WCMFORMFIELDS表：

描述：

自定义表单字段信息(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
WCMFORMFIELDSID | 编号 |  |  | int |  |
FORMID | 表单编号 |  |  | int |  |
FIELDNAME | 字段名 |  |  | nvarchar | 100 |
FIELDDESC | 说明 |  |  | nvarchar | 300 |
FIELDDBNAME | 数据库字段名 |  |  | nvarchar | 100 |


WCMFORMINFO

WCMFORMINFO表：

描述：

自定义表单信息 (保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
WCMFORMINFOID | --列说明-- |  |  | int |  |
FORMNAME | --列说明-- |  |  | nvarchar | 100 |
FORMTYPE | --列说明-- | 1 |  | int |  |
FORMOBJNAME | --列说明-- |  |  | nvarchar | 50 |
FORMOBJSNAME | --列说明-- |  |  | nvarchar | 50 |
FORMOBJPATH | --列说明-- |  |  | nvarchar | 200 |
FORMOBJSPATH | --列说明-- |  |  | nvarchar | 200 |
FORMDESC | --列说明-- |  |  | nvarchar | 400 |
SITEID | --列说明-- | 0 |  | int |  |
CHANNELID | --列说明-- | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMGROUP

WCMGROUP表：

描述：

系统用户组信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
GROUPID | 编号 |  |  | int |  |
GNAME | 名称 |  |  | nvarchar | 50 |
GDESC | 说明描述 |  |  | nvarchar | 200 |
PARENTID | 父组编号 |  |  | int |  |
EMAIL | 电子邮件地址 |  |  | char | 200 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMGRPUSER

WCMGRPUSER表：

描述：

用户与用户组的关联关系

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
GRPUSERID | 编号 |  |  | int |  |
GROUPID | 用户组编号 |  |  | int |  | WCMGROUP.GROUPID
USERID | 用户编号 |  |  | int |  | WCMUSER.USERID
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
ISADMINISTRATOR | 是否是组管理员 | 0 |  | smallint |  |


WCMHELP

WCMHELP表：

描述：

系统帮助 (保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
WCMHELPID | 编号 |  |  | int |  |
JSPURL | 链接地址 |  |  | nvarchar | 100 |
CONTENT | 内容 |  |  | ntext |  |
KEYWORDS | 关键词 |  |  | nvarchar | 100 |
TITLE | 标题 |  |  | nvarchar | 500 |
HTML | HTML内容 |  |  | ntext |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMHITSCOUNT

WCMHITSCOUNT表：

描述：

点击数

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
HITSCOUNTID | 编号 |  |  | int |  |
OBJTYPE | 对象类型 | 0 |  | int |  |
OBJID | 对象编号 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMID

WCMID表：

描述：

WCM对象编号维护信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TABLENAME | 对象存储表名 |  |  | nvarchar | 50 |
NEXTID | 下一个编号(ID) | 1 |  | int |  |
CACHESIZE | 缓冲大小 | 20 |  | smallint |  |


WCMINFOVIEW

WCMINFOVIEW表：

描述：

自定义表单信息(InfoPath)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
INFOVIEWID | 编号 |  |  | int |  |
SITEID | 表单所属站点编号 |  |  | int |  |
INFOVIEWNAME | 名称 |  |  | nvarchar | 50 |
INFOVIEWDESC | 描述 |  |  | nvarchar | 200 |
TITLEPATTERN | 表单标题模式 |  |  | nvarchar | 200 |
CRTIME | 对象创建时间 |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
INFOVIEWPATH | --列说明-- |  |  | nvarchar | 50 |
INFOPATHFILE | --列说明-- |  |  | nvarchar | 50 |
ALLFILELIST | --列说明-- |  |  | nvarchar | 400 |
SCHEMAFILE | --列说明-- |  |  | nvarchar | 50 |
TEMPLATEFILE | --列说明-- |  |  | nvarchar | 50 |
XSLTFILE | --列说明-- |  |  | nvarchar | 50 |
NEWXSLTFILE | --列说明-- |  |  | nvarchar | 50 |
HASDOCSERIAL | --列说明-- | 0 |  | tinyint |  |
SERIALPATTERN | --列说明-- |  |  | nvarchar | 100 |
SERIALPERIOD | --列说明-- | 0 |  | tinyint |  |
SERIALFIELD | --列说明-- |  |  | nvarchar | 100 |
REPLYNOTICEREQUIRED | --列说明-- | 0 |  | tinyint |  |
NOTICERELATEDFIELD | --列说明-- |  |  | nvarchar | 50 |
NOTICESUBJECTPATTERN | --列说明-- |  |  | nvarchar | 100 |
NOTICECONTENTPATTERN | --列说明-- |  |  | nvarchar | 400 |
OUTLINEFIELDS | --列说明-- |  |  | nvarchar | 1000 |
SEARCHFIELDS | --列说明-- |  |  | nvarchar | 1000 |
DOCCONTENTPATTERN | --列说明-- |  |  | varchar | 1000 |
OUTLINEDBFIELDS | --列说明-- |  |  | nvarchar | 1000 |
SEARCHDBFIELDS | --列说明-- |  |  | nvarchar | 1000 |


WCMINFOVIEWEMPLOY

WCMINFOVIEWEMPLOY表：

描述：

自定义表单与使用者的关联关系信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
INFOVIEWEMPLOYID | 编号 |  |  | int |  |
INFOVIEWID | 自定义表单编号 |  |  | int |  | WCMINFOVIEW.INFOVIEWID
EMPLOYERTYPE | 使用表单的对象类型 |  |  | int |  |
EMPLOYERID | 使用表单的对象编号 |  |  | int |  |


WCMINFOVIEWFIELD

WCMINFOVIEWFIELD表：

描述：

自定义表单：表单字段

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
IVFIELDID | 编号 |  |  | int |  |
INFOVIEWID | 所属表单编号 |  |  | int |  | WCMINFOVIEW.INFOVIEWID
FIELDNAME | 字段名称 |  |  | nvarchar | 100 |
FIELDDESC | 字段描述说明 |  |  | nvarchar | 100 |
PUBLICFILL | 是否公开可填写 |  |  | tinyint |  |
PUBLICVIEW | 是否可公开查看内容 |  |  | tinyint |  |
SPECIALRIGHT | 是否有特殊权限 |  |  | tinyint |  |
NILLABLE | 是否允许空值 |  |  | tinyint |  |
DATATYPE | 字段数字类型 |  |  | int |  |
DATAPATTERN | 数据范式 |  |  | nvarchar | 50 | 数据范式
MAXLENGTH | 允许的最大长度/值 |  |  | int |  |
MINLENGTH | 允许的最小长度/值 |  |  | int |  |
FIXLENGTH | 固定长度 |  |  | int |  |
FIELDTYPE | 字段类型 |  |  | varchar | 50 |
DATACONTROL | 数据控制 |  |  | varchar | 200 |
DEFAULTVALUE | 默认值 |  |  | nvarchar | 200 |
ENUMVALUE | 枚举可选值 |  |  | nvarchar | 200 |
CLASSID | 分类编号 |  |  | int |  |
INOUTLINE | 概览显示 |  |  | tinyint |  |
INSEARCH | 是否可检索 |  |  | tinyint |  |
XSLTXPATH | XSLT相关表达式 |  |  | nvarchar | 100 |
GATEWAYBINDING | infogate绑定内容 |  |  | nvarchar | 200 |
READONLY | 只读字段 |  |  | tinyint |  |

备注

  1. 数据范式:指可以动态置换的一些内容,如${cruser}等


WCMINFOVIEWGROUP

WCMINFOVIEWGROUP表：

描述：

自定义表单一个视图内部的数据块，对应InfoPath的Section或者Reapeating Table

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
IVGROUPID | 编号 |  |  | int |  |
INFOVIEWID | 所属表单编号 |  |  | int |  | WCMINFOVIEW.INFOVIEWID
IVVIEWID | 所属视图编号 | 0 |  | int |  | WCMINFOVIEWVIEW.IVVIEWID
GROUPNAME | 分组名称 |  |  | nvarchar | 50 |
GROUPDESC | 分组描述 |  |  | nvarchar | 200 |
PUBLICFILL | 是否公开可填写 | 1 |  | tinyint |  |
PUBLICVIEW | 是否公开可查看 | 1 |  | tinyint |  |
SPECIALRIGHT | 是否特殊权限可设置 | 0 |  | tinyint |  |


WCMINFOVIEWSERIAL

WCMINFOVIEWSERIAL表：

描述：

自定义表单:序号信息维护

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
PERIODPART | 时间部分 |  |  | nvarchar | 32 |
INFOVIEWID | 所属表单编号 |  |  | int |  | WCMINFOVIEW.INFOVIEWID
NEXTSERIAL | 下一个序号 | 1 |  | int |  |
BASESERIAL | 基线序号 | 1 |  | int |  |


WCMINFOVIEWVIEW

WCMINFOVIEWVIEW表：

描述：

自定义表单:内部视图(多视图表单)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
IVVIEWID | 编号 |  |  | int |  |
INFOVIEWID | 所属表单编号 |  |  | int |  | WCMINFOVIEW.INFOVIEWID
VIEWNAME | 视图名称 |  |  | nvarchar | 50 |
VIEWDESC | 视图描述说明 |  |  | nvarchar | 200 |
OLDXSLFILE | 旧的xsl文件 |  |  | nvarchar | 50 |
NEWXSLFILE | 新的xsl文件 |  |  | nvarchar | 50 |
VIEWWIDTH | 视图宽度 |  |  | nvarchar | 16 |
PUBLICFILL | 是否可公开填写 | 1 |  | tinyint |  |
PUBLICVIEW | 是否可公开查看 | 1 |  | tinyint |  |
DEFAULTVIEW | 是否为默认视图 | 1 |  | tinyint |  |
SPECIALRIGHT | 特殊权限 | 0 |  | tinyint |  |
XSLPREFIX | xsl表达式前缀 |  |  | nvarchar | 50 |


WCMJOB

WCMJOB表：

描述：

系统定时任务信息(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
JOBID | 编号 |  |  | int |  |
OPERTYPE | --列说明-- |  |  | int |  |
PARAMS | --列说明-- |  |  | nvarchar | 200 |
STATUS | --列说明-- | 0 |  | smallint |  |
STARTTIME | --列说明-- |  |  | datetime |  |
EXPIRETIME | --列说明-- |  |  | datetime |  |
LASTEXETIME | --列说明-- |  |  | datetime |  |
FAILCOUNT | --列说明-- | 0 |  | smallint |  |
TIMEUSED | --列说明-- | 0 |  | int |  |
PRIORITY | --列说明-- | 0 |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
SENDERTYPE | --列说明-- | 0 |  | int |  |
SENDERID | --列说明-- | 0 |  | int |  |


WCMJOBEXERESULT

WCMJOBEXERESULT表：

描述：

系统定时任务执行结果

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RESULTID | 编号 |  |  | int |  |
JOBSCHEDULEID | 计划任务编号 |  |  | int |  | WCMSCHEDULE.SCHID
JOBFAIELDROOTCAUSE | 任务失败原因 |  |  | nvarchar | 500 |
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMLOG

WCMLOG表：

描述：

操作日志信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
LOGID | 编号 |  |  | int |  |
LOGTYPE | 日志类型 |  |  | int |  |
LOGDESC | 日志描述 |  |  | nvarchar | 3000 |
LOGOBJNAME | 操作对象名称 |  |  | nvarchar | 3000 |
LOGOBJTYPE | 操作对象类型 |  |  | int |  |
LOGOBJID | 操作对象编号 |  |  | int |  |
LOGOPTYPE | 操作类型 |  |  | int |  |
LOGOPARGS | 操作参数 |  |  | nvarchar | 1000 |
LOGRESULT | 操作结果 |  |  | smallint |  |
LOGUSER | 操作用户 |  |  | nvarchar | 50 | WCMUSER.USERNAME
LOGOPTIME | 操作时间 |  |  | datetime |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 1000 |
PARENTID | 父日志编号 | 0 |  | int |  |
STIMEMILLIS | 操作开始时间戳 | 0 |  | numeric |  |
ETIMEMILLIS | 操作结束时间戳 |  |  | numeric |  |
EXECTIME | 操作执行耗时 | 0 |  | numeric |  |
LOGUSERIP | 操作用户的登录IP |  |  | nvarchar | 50 |
TOPID | 顶层日志编号 | 0 |  | int |  |
SIGNINFO | 签名信息 |  |  | nvarchar | 1000 |


WCMLOGBAK

WCMLOGBAK表：

描述：

日志备份表(保留,见WCMLOG表)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
LOGBAKID | 编号 |  |  | int |  |
BAKUSER | 备份用户 |  |  | nvarchar | 50 |
BAKTIME | 备份时间 |  |  | datetime |  |
LOGUSERIP | --列说明-- |  |  | nvarchar | 50 |
TOPID | --列说明-- |  |  | int |  |
LOGID | --列说明-- |  |  | int |  |
LOGTYPE | --列说明-- |  |  | int |  |
LOGDESC | --列说明-- |  |  | nvarchar | 3000 |
LOGOBJNAME | --列说明-- |  |  | nvarchar | 3000 |
LOGOBJTYPE | --列说明-- |  |  | int |  |
LOGOBJID | --列说明-- |  |  | int |  |
LOGOPTYPE | --列说明-- |  |  | int |  |
LOGOPARGS | --列说明-- |  |  | nvarchar | 1000 |
LOGRESULT | --列说明-- |  |  | smallint |  |
LOGUSER | --列说明-- |  |  | nvarchar | 50 |
LOGOPTIME | --列说明-- |  |  | datetime |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 1000 |
PARENTID | --列说明-- | 0 |  | int |  |
STIMEMILLIS | --列说明-- | 0 |  | numeric |  |
ETIMEMILLIS | --列说明-- |  |  | numeric |  |
EXECTIME | --列说明-- | 0 |  | numeric |  |


WCMLOGTYPE

WCMLOGTYPE表：

描述：

日志类型

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
LOGTYPEID | 编号 |  |  | smallint |  |
TYPENAME | 名称 |  |  | nvarchar | 50 |
TYPEDISP | 显示名称 |  |  | nvarchar | 50 |
TYPEDESC | 说明描述 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMMARKKIND

WCMMARKKIND表：

描述：

书签文件夹(分类)信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
KINDID | 编号 |  |  | int |  |
PARENTID | 父分类编号 | 0 |  | int |  |
KNAME | 名称 |  |  | nvarchar | 200 |
KDESC | 说明描述 |  |  | nvarchar | 200 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMMARKSHARE

WCMMARKSHARE表：

描述：

共享书签信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SHAREID | 编号 |  |  | int |  |
OBJTYPE | 共享该书签的对象类型 |  |  | int |  |
OBJID | 共享该书签的对象编号 |  |  | int |  |
VIEWERTYPE | 可查看共享书签的对象类型 |  |  | int |  |
VIEWERID | 可查看共享书签的对象编号 |  |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMMEETINGCONT

WCMMEETINGCONT表：

描述：

网络会议的内容(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CONTENTID | 编号 |  |  | int |  |
ROOMID | 会议编号 |  |  | int |  | WCMMEETINGROOM.ROOMID
CONTENT | 内容 |  |  | nvarchar | 200 |
LISTENERID | 内容接受者 |  |  | int |  |
ISPRIVATE | 是否是私密会议 | 0 |  | tinyint |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMMEETINGROOM

WCMMEETINGROOM表：

描述：

网络会议室信息保留

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ROOMID | 编号 |  |  | int |  |
ROOMNAME | 会议室名称 |  |  | nvarchar | 50 |
ROOMDESC | 描述说明 |  |  | nvarchar | 200 |
STATUS | 状态 |  |  | tinyint |  |
STARTTIME | 开始时间 |  |  | datetime |  |
ATTENDEES | 会议出席人员 |  |  | nvarchar | 500 |
ONLINEREMIND | 在线消息提醒 | 0 |  | tinyint |  |
EMAILREMIND | 电子邮件提醒 | 0 |  | tinyint |  |
AHEADREMINDTIME | 提前提醒时间 | 10 |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMMEETINGUSER

WCMMEETINGUSER表：

描述：

网络会议的参加用户

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
MEETINGUSERID | 编号 |  |  | int |  |
ROOMID | 会议编号 |  |  | int |  | WCMMEETINGROOM.ROOMID
USERID | 用户编号 |  |  | int |  | WCMUSER.USERID
USERSTATUS | 与会用户当前状态 |  |  | tinyint |  |
LOGINTIME | 与会用户登录时间 |  |  | datetime |  |
EXITTIME | 与会用户离开时间 |  |  | datetime |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |


WCMMESSAGE

WCMMESSAGE表：

描述：

在线短消息记录

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
MSGID | 编号 |  |  | int |  |
FLAG | 标记 |  |  | smallint |  |
TITLE | 标题 |  |  | nvarchar | 200 |
MBODY | 详细内容 |  |  | nvarchar | 1000 |
VALID | 有效时间 |  |  | datetime |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
MSGTYPE | 类型 | 1 |  | int |  |
SENDTYPE | 发送方式 | 1 |  | nvarchar | 50 |
DELETEDBYSENDER | 是否被分发者删除 | 0 |  | int |  |
MSGRECEIVER | 接收者 |  |  | nvarchar | 50 |
BIGMBODY | 内容(当前消息内容很长时使用) |  |  | text |  |


WCMMSGQUEUE

WCMMSGQUEUE表：

描述：

消息分发信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
QUEUEID | 编号 |  |  | int |  |
MSGID | 消息编号 |  |  | int |  | WCMMESSAGE.MSGID
OBJTYPE | 接收消息的对象类型 |  |  | int |  |
OBJID | 接收消息的对象编号 |  |  | int |  |
READED | 是否已读 | 0 |  | tinyint |  |
MSGTYPE | 类型 | 1 |  | int |  |
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMMSGRECEIVER

WCMMSGRECEIVER表：

描述：

消息接收者信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
MSGRECEIVERID | 编号 | 0 |  | int |  |
MSGID | 消息编号 | 0 |  | int |  | WCMMESSAGE.MSGID
RECEIVERID | 接收者编号 | 0 |  | int |  |
RECEIVERTYPE | 接收者类型 | 0 |  | int |  |
RECEIVERNAME | 接收者名称 |  |  | nvarchar | 50 |


WCMOBJTRIGGER

WCMOBJTRIGGER表：

描述：

定时任务触发器(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TRIGGERID | --列说明-- |  |  | int |  |
TRIGGERNAME | --列说明-- |  |  | nvarchar | 50 |
TRIGGERPATH | --列说明-- |  |  | nvarchar | 60 |
TRIGGERDESC | --列说明-- |  |  | nvarchar | 200 |
TRIGGERTYPE | --列说明-- |  |  | int |  |
WCMOBJTYPE | --列说明-- |  |  | int |  |


WCMOPER

WCMOPER表：

描述：

系统操作类型

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
OPERID | 编号 |  |  | int |  |
PARAM | 参数 |  |  | nvarchar | 200 |
OPNAME | 名称 |  |  | nvarchar | 50 |
OPDESC | 说明描述 |  |  | nvarchar | 200 |
OPBEAN | 操作执行的BEAN |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMOPERATIONBEAN

WCMOPERATIONBEAN表：

描述：

系统操作BEAN(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
OPERATIONBEANID | --列说明-- |  |  | int |  |
BEANNAME | --列说明-- |  |  | nvarchar | 50 |
BEANPATH | --列说明-- |  |  | nvarchar | 60 |
OPERATIONDESC | --列说明-- |  |  | nvarchar | 200 |
PARAMETERS | --列说明-- |  |  | nvarchar | 1000 |
SETURL | --列说明-- |  |  | nvarchar | 100 |


WCMOPERTYPE

WCMOPERTYPE表：

描述：

系统操作类型信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
OPERTYPEID | 编号 |  |  | int |  |
NAME | 名称 |  |  | nvarchar | 50 |
OPERTYPEDESC | 描述说明 |  |  | nvarchar | 50 |
CRTIME | 对象创建时间 |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME


WCMPUBLISHCONFIG

WCMPUBLISHCONFIG表：

描述：

发布属性配置,FACAD对象(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
PUBLISHCONFIGID | --列说明-- |  |  | int |  |
OBJTYPE | --列说明-- |  |  | int |  |
OBJID | --列说明-- |  |  | int |  |
OUTLINEPREFIX | --列说明-- |  |  | nvarchar | 100 |
OUTLINEEXT | --列说明-- |  |  | nvarchar | 50 |
DETAILEXT | --列说明-- |  |  | nvarchar | 50 |
STATUSAFTERUPDATE | --列说明-- |  |  | int |  |
STATUSIDSALLOWPUB | --列说明-- |  |  | nvarchar | 200 |
SCHEDULEID | --列说明-- |  |  | int |  |
OUTLINETEMPLATEID | --列说明-- |  |  | int |  |
DETAILTEMPLATEID | --列说明-- |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMPUBLISHDISTRIBUTION

WCMPUBLISHDISTRIBUTION表：

描述：

发布分发

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
PUBLISHDISTRIBUTIONID | 编号 |  |  | int |  |
FOLDERTYPE | 文件夹类型 |  |  | int |  |
FOLDERID | 文件夹编号 |  |  | int |  |
TARGETTYPE | 分发目标类型 | 'FILE' |  | nvarchar | 50 |
TARGETSERVER | 分发目标服务器地址 |  |  | nvarchar | 200 |
LOGINUSER | 登录用户 |  |  | nvarchar | 50 |
LOGINPASSWORD | 登录密码 |  |  | nvarchar | 20 |
DATAPATH | 存放位置 |  |  | nvarchar | 200 |
ENABLED | 启用配置 | 1 |  | tinyint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
ANONYMFTP | 使用匿名FTP | 0 |  | tinyint |  |
TARGETPORT | 目标服务器端口 | 0 |  | int |  |
PASSIVEMODE | 使用FTP被动模式 | 1 |  | tinyint |  |


WCMPUBLISHERRORLOG

WCMPUBLISHERRORLOG表：

描述：

发布错误日志信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
PUBLISHERRORLOGID | 编号 |  |  | int |  |
PUBLISHTASKID | 发布任务编号 |  |  | int |  | WCMPUBLISHTASK.PUBLISHTASKID
FOLDERTYPE | 文件夹类型 |  |  | int |  |
FOLDERID | 文件夹编号 |  |  | int |  |
CONTENTTYPE | 内容对象类型 | 0 |  | int |  |
CONTENTID | 内容对象编号 | 0 |  | int |  |
PAGETASKDESC | 页面任务描述 |  |  | nvarchar | 400 |
EXERESULT | 执行结果 |  |  | int |  |
ERRORDETAIL | 错误详细信息 |  |  | nvarchar | 4000 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMPUBLISHTASK

WCMPUBLISHTASK表：

描述：

发布任务信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
PUBLISHTASKID | 编号 |  |  | int |  |
PUBLISHTYPE | 发布类型 |  |  | int |  |
TASKPRIORITY | 任务优先级 |  |  | int |  |
TASKSTATUS | 任务所处状态 |  |  | int |  |
FOLDERTYPE | 发布的文件夹类型 |  |  | int |  |
FOLDERID | 发布的文件夹编号 |  |  | int |  |
CONTENTIDS | 发布的内容编号序列 |  |  | nvarchar | 400 |
TASKTITLE | 任务简要说明 |  |  | nvarchar | 400 |
TASKDESC | 任务描述 |  |  | nvarchar | 3000 |
STARTTIME | 任务开始时间 |  |  | datetime |  |
ENDTIME | 任务结束时间 |  |  | datetime |  |
TIMEUSED | 发布耗时 | 0 |  | int |  |
PAGETASKCOUNT | 页面任务计数 | 0 |  | int |  |
HASWARNINGS | 是否有潜在错误警告 | 0 |  | smallint |  |
ANALYZEERROR | 任务分析错误信息 |  |  | nvarchar | 2000 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
CONTENTTYPE | 发布内容的对象类型 | 0 |  | int |  |
TASKURL | 任务链接 |  |  | nvarchar | 500 |
DETAILPAGES | 任务发布的细览页面数 | 0 |  | int |  |
OUTLINEPAGES | 任务发布的概览页面数 | 0 |  | int |  |
FOLDERIDS | 发布的文件夹编号序列 |  |  | nvarchar | 400 |
ISSCHEDULEDTASK | 是否为计划发布任务 | 0 |  | tinyint |  |


WCMPUBSTATUSCONFIG

WCMPUBSTATUSCONFIG表：

描述：

可发布状态配置信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
WCMPUBSTATUSCONFIGID | 编号 |  |  | int |  |
FOLDERTYPE | 文件夹类型 |  |  | int |  |
FOLDERID | 文件夹编号 |  |  | int |  |
STATUSESCANDOPUB | 可发布状态编号序列 |  |  | nvarchar | 50 |
STATUSIDAFTERMODIFY | 已发状态被编辑后的变化目标状态 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMRECENT

WCMRECENT表：

描述：

用户最近操作对象

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECENTID | 编号 |  |  | int |  |
OBJTYPE | 对象类型 |  |  | int |  |
OBJID | 对象编号 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMRELATION

WCMRELATION表：

描述：

相关文档信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RELATIONID | 编号 |  |  | int |  |
DOCID | 文档编号 |  |  | int |  | WCMDOCUMENT.DOCID
RELDOCID | 指定的相关文档编号 |  |  | int |  |
SERN | 序号 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMREPLACE

WCMREPLACE表：

描述：

替换内容

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
REPLACEID | 编号 |  |  | int |  |
REPLACENAME | 名称 |  |  | nvarchar | 100 |
REPLACECONTENT | 替换的内容 |  |  | nvarchar | 1000 |
CHNLID | 所属栏目 |  |  | int |  | WCMCHANNEL.CHANNELID


WCMRIGHT

WCMRIGHT表：

描述：

权限信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RIGHTID | 编号 |  |  | int |  |
OBJTYPE | 权限所属对象类型 |  |  | int |  |
OBJID | 权限所属对象编号 |  |  | int |  |
OPRTYPE | 授权操作类型 |  |  | int |  |
OPRID | 授权操作编号 |  |  | int |  |
RIGHTVALUE | 所授权限的值 | 0 |  | numeric |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMRIGHTDEF

WCMRIGHTDEF表：

描述：

权限定义

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RIGHTDEFID | 编号 |  |  | int |  |
OBJTYPE | 对象类型 |  |  | int |  |
RIGHTINDEX | 权限索引编号 |  |  | tinyint |  |
RIGHTNAME | 权限名称 |  |  | nvarchar | 50 |
RIGHTDESC | 描述说明 |  |  | nvarchar | 200 |
SYSDEFINED | 是否系统预定义权限 | 0 |  | smallint |  |


WCMROLE

WCMROLE表：

描述：

系统角色信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ROLEID | 编号 |  |  | int |  |
ROLENAME | 名称 |  |  | nvarchar | 50 |
ROLEDESC | 描述说明 |  |  | nvarchar | 200 |
EMAIL | 邮件地址 |  |  | nvarchar | 200 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
SYSDEFINED | 是否是系统预定义角色 | 0 |  | int |  |
VIEWABLE | 是否可见 | 1 |  | smallint |  |
REMOVEABLE | 是否可删除 | 1 |  | smallint |  |


WCMROLEUSER

WCMROLEUSER表：

描述：

系统用户与角色的关联类系

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ROLEUSERID | 编号 | 0 |  | int |  |
ROLEID | 角色编号 |  |  | int |  | WCMROLE.ROLEID
USERID | 用户编号 |  |  | int |  | WMCUSER.USERID
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMSCHEDULE

WCMSCHEDULE表：

描述：

系统计划任务信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SCHID | 编号 |  |  | int |  |
SCHNAME | 名称 |  |  | nvarchar | 300 |
SCHDESC | 描述说明 |  |  | nvarchar | 200 |
OPTYPE | 任务调度类型 |  |  | int |  | WCMOPER.OPERID
OPARGS | 调度参数 |  |  | nvarchar | 1000 |
SCHMODE | 调度类型 |  |  | smallint |  | 类型
SDATE | 任务开始时间 |  |  | datetime |  |
EDATE | 任务结束时间 |  |  | datetime |  |
ETIME | 任务执行时间 |  |  | datetime |  |
PARAM | 任务间隔时间 |  |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 1000 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
LASTEXETIME | 任务上次执行时间 |  |  | datetime |  |
LASTEXERES | 任务上次执行是否成功 |  |  | smallint |  | 保留
LASTTIMEUSED | 执行耗时 | 0 |  | int |  |
SENDERTYPE | 计划任务请求者类型 | 0 |  | int |  |
SENDERID | 计划任务请求者编号 | 0 |  | int |  |
SCHSTATUS | 当前状态 | 1 |  | smallint |  | 保留

备注

  1. 类型：共三种类型[只运动一次=3,每天运行多次=2,每天运行一次=1]
  2. SDATE,EDATE,PARAM只对每天运行多次有效
  3. ETIME对每天运行多次的计划无效


WCMSECUREKEY

WCMSECUREKEY表：

描述：

系统私/公钥信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SECUREKEYID | 编号 |  |  | int |  |
KEYNAME | 密钥名称 |  |  | nvarchar | 64 |
KEYSIZE | 密钥长度 |  |  | int |  |
ALGORITHM | 密钥使用的算法 |  |  | nvarchar | 128 |
PRIVATEKEY | 私钥 |  |  | nvarchar | 2048 |
PUBLICKEY | 公钥 |  |  | nvarchar | 2048 |

备注

  1. 在表单等选件中使用,主要是使数据交换更可信


WCMSECURITY

WCMSECURITY表：

描述：

文档的安全级别

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SECURITYID | 编号 |  |  | int |  |
SNAME | 名称 |  |  | nvarchar | 50 |
SDESC | 描述说明 |  |  | nvarchar | 200 |
SDISP | 显示名称 |  |  | nvarchar | 200 |
SVALUE | 取值 |  |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMSITEEXTFIELD

WCMSITEEXTFIELD表：

描述：

站点扩展字段(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SITEID | --列说明-- |  |  | int |  |
EXTFIELDID | --列说明-- |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMSITEUSER

WCMSITEUSER表：

描述：

站点用户/用户组/角色等信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SITEUSERID | 编号 |  |  | int |  |
SITEID | 站点编号 |  |  | int |  | WCMWEBSITE.SITEID
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
OBJID | 对象编号 |  |  | int |  |
OBJTYPE | 对象类型 |  |  | int |  |


WCMSOURCE

WCMSOURCE表：

描述：

文档来源

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SOURCEID | 编号 |  |  | int |  |
SRCNAME | 名称 |  |  | nvarchar | 50 |
SRCDESC | 描述说明 |  |  | nvarchar | 200 |
SRCLINK | 来源链接地址 |  |  | nvarchar | 200 |
SECURITY | 安全级别 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
PRICE | 文档单价 | 0 |  | int |  |
SITEID | 所属站点编号 | 1 |  | int |  |
SOURCEORDER | 序号 |  |  | int |  |


WCMSTAT_CHANNEL_GENERAL

WCMSTAT_CHANNEL_GENERAL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
CHANNELID | --列说明-- |  |  | int |  |
SITENAME | --列说明-- |  |  | nvarchar | 1 |
CHNLNAME | --列说明-- |  |  | nvarchar | 1 |
ALLDOCCOUNT | --列说明-- |  |  | int |  |
ALLWORDSCOUNT | --列说明-- |  |  | int |  |
PUBDOCCOUNT | --列说明-- |  |  | int |  |
PUBWORDSCOUNT | --列说明-- |  |  | int |  |


WCMSTAT_CHANNEL_TEMPLATE

WCMSTAT_CHANNEL_TEMPLATE表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
CHANNELID | --列说明-- |  |  | int |  |
SITENAME | --列说明-- |  |  | nvarchar | 1 |
CHNLNAME | --列说明-- |  |  | nvarchar | 1 |
TEMPCOUNT | --列说明-- |  |  | int |  |


WCMSTAT_DOCSOURCE_PUBALL

WCMSTAT_DOCSOURCE_PUBALL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
SOURCEID | --列说明-- |  |  | int |  |
SRCNAME | --列说明-- |  |  | nvarchar | 1 |
ALLWORDSCOUNT | --列说明-- |  |  | int |  |
ALLDOCCOUNT | --列说明-- |  |  | int |  |
PUBWORDSCOUNT | --列说明-- |  |  | int |  |
PUBDOCCOUNT | --列说明-- |  |  | int |  |
PRICE | --列说明-- |  |  | int |  |
TOTALPRICE | --列说明-- |  |  | int |  |


WCMSTAT_GROUP_GENERAL

WCMSTAT_GROUP_GENERAL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
GROUPID | --列说明-- |  |  | int |  |
GNAME | --列说明-- |  |  | nvarchar | 1 |
ALLDOCCOUNT | --列说明-- |  |  | int |  |
ALLWORDSCOUNT | --列说明-- |  |  | int |  |
CHNLCOUNT | --列说明-- |  |  | int |  |
TEMPCOUNT | --列说明-- |  |  | int |  |


WCMSTAT_SITE_GENERAL

WCMSTAT_SITE_GENERAL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
SITEID | --列说明-- |  |  | int |  |
SITENAME | --列说明-- |  |  | nvarchar | 1 |
ALLDOCCOUNT | --列说明-- |  |  | int |  |
ALLWORDSCOUNT | --列说明-- |  |  | int |  |
PUBDOCCOUNT | --列说明-- |  |  | int |  |
PUBWORDSCOUNT | --列说明-- |  |  | int |  |
CHNLCOUNT | --列说明-- |  |  | int |  |
TEMPCOUNT | --列说明-- |  |  | int |  |


WCMSTAT_USER_GENERAL

WCMSTAT_USER_GENERAL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
USERID | --列说明-- |  |  | int |  |
USERNAME | --列说明-- |  |  | int |  |
ALLDOCCOUNT | --列说明-- |  |  | int |  |
ALLWORDSCOUNT | --列说明-- |  |  | int |  |
CHNLCOUNT | --列说明-- |  |  | int |  |
TEMPCOUNT | --列说明-- |  |  | int |  |


WCMSTAT_WORKFLOW_GROUP_GENERAL

WCMSTAT_WORKFLOW_GROUP_GENERAL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
GROUPID | --列说明-- |  |  | int |  |
GNAME | --列说明-- |  |  | nvarchar | 200 |
PROCESSDOCCOUNT | --列说明-- |  |  | int |  |
STARTUPDOCCOUNT | --列说明-- |  |  | int |  |


WCMSTAT_WORKFLOW_USER_GENERAL

WCMSTAT_WORKFLOW_USER_GENERAL表：

描述：

统计表(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | --列说明-- |  |  | int |  |
STATTIME | --列说明-- |  |  | datetime |  |
USERID | --列说明-- |  |  | int |  |
USERNAME | --列说明-- |  |  | nvarchar | 200 |
PROCESSDOCCOUNT | --列说明-- |  |  | int |  |
STARTUPDOCCOUNT | --列说明-- |  |  | int |  |


WCMSTATFIELDMAP

WCMSTATFIELDMAP表：

描述：

统计表字段映射

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
STATFIELDMAPID | 编号 |  |  | int |  |
STATVIEWID | 所属视图编号 |  |  | int |  | WCMSTATVIEW.STATVIEWID
FIELDPOS | 位置 |  |  | int |  |
FIELDNAME | 名称 |  |  | nvarchar | 100 |
FIELDDESC | 描述说明 |  |  | nvarchar | 200 |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 2000 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
FIELDTYPE | 类型 |  |  | nvarchar | 30 |
FIELDLENGTH | 长度 |  |  | int |  |
EMBEDDEDVIEWID | 嵌套视图编号 |  |  | int |  |
FIELDTOP | 是否是首字段 | 0 |  | smallint |  |


WCMSTATHOST

WCMSTATHOST表：

描述：

统计主体

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
STATHOSTID | 编号 |  |  | int |  |
HOSTNAME | 名称 |  |  | nvarchar | 100 |
HOSTDESC | 描述说明 |  |  | nvarchar | 200 |
WCMTABLENAME | WCM系统表名 |  |  | nvarchar | 100 | 保留
HOSTTYPE | 主体类型 |  |  | int |  |
WCMTABLEID | WCM系统表编号 |  |  | nvarchar | 100 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMSTATUS

WCMSTATUS表：

描述：

文档状态信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
STATUSID | 编号 |  |  | int |  |
SNAME | 名称 |  |  | nvarchar | 50 |
SDESC | 描述说明 |  |  | nvarchar | 200 |
SDISP | 显示名称 |  |  | nvarchar | 200 |
SUSED | 是否被使用 |  |  | tinyint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
RIGHTINDEX | 权限索引 | 35 |  | smallint |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |


WCMSTATVIEW

WCMSTATVIEW表：

描述：

统计视图

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
STATVIEWID | 编号 |  |  | int |  |
VIEWNAME | 名称 |  |  | nvarchar | 100 |
VIEWDESC | 描述说明 |  |  | nvarchar | 200 |
VIEWTYPE | 视图类型 |  |  | int |  |
STATHOST | 所属统计主体 |  |  | nvarchar | 100 | WCMSTATHOST.HOSTNAME
RESULTTABLE | 统计结果存储表名 |  |  | nvarchar | 100 |
VIEWSELECT | 统计select部分 |  |  | nvarchar | 1000 |
VIEWFROM | 统计from部分 |  |  | nvarchar | 1000 |
VIEWWHERE | 统计where部分 |  |  | nvarchar | 1000 |
VIEWORDERBY | 统计order by 部分 |  |  | nvarchar | 200 |
VIEWGROUPBY | 统计group by 部分 |  |  | nvarchar | 200 |
VIEWATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
TIMEFIELD | 时间字段 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMSTATVIEWREL

WCMSTATVIEWREL表：

描述：

统计视图关联关系

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
STATVIEWRELID | 编号 |  |  | int |  |
MAINVIEWID | 主视图编号 |  |  | int |  |
EMBEDVIEWID | 子视图编号 |  |  | int |  |


WCMTAGBEANS

WCMTAGBEANS表：

描述：

模板置标解释Bean

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TAGBEANID | 编号 |  |  | int |  |
TAGNAME | 置标名称 |  |  | nvarchar | 50 |
TAGBEAN | 解释Bean |  |  | nvarchar | 400 |
TAGDESC | 置标描述说明 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
ENABLED | 是否启用 | 1 |  | smallint |  |


WCMTASK

WCMTASK表：

描述：

日程安排中的任务信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TASKID | 编号 |  |  | int |  |
TITLE | 标题 |  |  | nvarchar | 50 |
TDESC | 描述说明 |  |  | nvarchar | 200 |
TSTART | 开始时间 |  |  | datetime |  |
TEND | 结束时间 |  |  | datetime |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
TPERCENT | --列说明-- | 0 |  | tinyint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


WCMTASKPOOL

WCMTASKPOOL表：

描述：

日程安排中的任务共享

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
POOLID | 编号 |  |  | int |  |
TASKID | 任务编号 |  |  | int |  | WCMTASK.TASKID
OBJTYPE | 对象类型 |  |  | int |  |
OBJID | 对象编号 |  |  | int |  |
VALID | 有效时间 |  |  | datetime |  |
CANEDIT | 是否可编辑 |  |  | tinyint |  |


WCMTEMPAPDREL

WCMTEMPAPDREL表：

描述：

模板附件关联关系

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
RECID | 编号 | 0 |  | int |  |
TEMPID | 模板编号 |  |  | int |  | WCMTEMPLATE.TEMPID
APPENDIXID | 模板附件编号 |  |  | int |  | WCMTEMPLATEAPD.TEMPAPPENDIXID


WCMTEMPAPPENDIX

WCMTEMPAPPENDIX表：

描述：

模板附件

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPAPPENDIXID | 编号 |  |  | int |  |
APDFILE | 文件名 |  |  | nvarchar | 256 |
APDFLAG | 标记 |  |  | int |  |
CRUSER | 对象创建者 |  |  | varchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 | getdate() |  | datetime |  |
ROOTTYPE | 所属文件夹类型 | 103 |  | int |  |
ROOTID | 所属文件夹编号 | 0 |  | int |  |


WCMTEMPLATE

WCMTEMPLATE表：

描述：

模板

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPID | 编号 |  |  | int |  |
TEMPNAME | 名称 |  |  | nvarchar | 150 |
TEMPDESC | 描述说明 |  |  | nvarchar | 200 |
TEMPEXT | 扩展名 | 'htm' |  | nvarchar | 50 |
TEMPTEXT | 内容 |  |  | ntext |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
APDMODIFIED | 附件是否有修改 | 0 |  | smallint |  |
TEMPTYPE | 类型 | 0 |  | smallint |  |
TEMPFORMID | 复制的模板编号 | 0 |  | int |  |
ISPARSED | 是否已解释 | 0 |  | smallint |  |
FOLDERTYPE | 所属文件夹类型 | 103 |  | int |  |
ROOTID | 所属根文件夹编号 | 0 |  | int |  |
FOLDERID | 所属文件夹编号 | 0 |  | int |  |
ROOTTYPE | 所属根文件夹类型 | 0 |  | int |  |
OUTPUTFILENAME | 输出文件名 |  |  | nvarchar | 50 |
LASTMODIFIEDUSER | 最后修改用户 |  |  | nvarchar | 60 |
LASTMODIFIEDTIME | 最后修改时间 |  |  | datetime |  |


WCMTEMPLATEARGUMENT

WCMTEMPLATEARGUMENT表：

描述：

模板变量

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPLATEARGUMENTID | 编号 |  |  | int |  |
EMPLOYERTYPE | 所属文件夹类型 |  |  | int |  |
EMPLOYERID | 所属文件夹编号 |  |  | int |  |
TEMPLATEID | 模板编号 |  |  | int |  | WCMTEMPLATE.TEMPID
ARGUMENTNAME | 变量名 |  |  | nvarchar | 256 |
ARGUMENTVALUE | 变量值 |  |  | nvarchar | 256 |
PREFIXOFNAME | 变量前缀名 |  |  | nvarchar | 256 |


WCMTEMPLATEEMPLOY

WCMTEMPLATEEMPLOY表：

描述：

模板配置使用信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPLATEEMPLOYID | 编号 |  |  | int |  |
EMPLOYERTYPE | 使用该模板的对象类型 |  |  | int |  |
EMPLOYERID | 使用该模板的对象编号 |  |  | int |  |
TEMPLATEID | 模板编号 |  |  | int |  | WCMTEMPLATE.TEMPID
TEMPLATETYPE | 模板类型 |  |  | smallint |  | WCMTEMPLATE.TEMPTYPE
ISDEFAULT | 是否是默认模板 | 0 |  | smallint |  |


WCMTEMPLATENEST

WCMTEMPLATENEST表：

描述：

嵌套模板信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPLATEID | 模板编号 |  |  | int |  |
NESTEDTEMPLATEID | 嵌套的模板编号 |  |  | int |  |


WCMTEMPLATEQUOTE

WCMTEMPLATEQUOTE表：

描述：

模板引用信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TEMPLATEQUOTEID | 编号 |  |  | int |  |
TEMPLATEID | 模板编号 |  |  | int |  |
TEMPLATETYPE | 模板类型 |  |  | smallint |  |
QUOTEDFOLDERTYPE | --列说明-- |  |  | int |  |
QUOTEDFOLDERID | --列说明-- |  |  | int |  |
FAMILYINDEX | --列说明-- | 0 |  | smallint |  |
QUOTETYPE | --列说明-- |  |  | smallint |  |


WCMTRUSTEEINFO

WCMTRUSTEEINFO表：

描述：

用户托管的信息(保留)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TRUSTEEINFOID | 编号 |  |  | int |  |
TRUSTEE | 托管内容 |  |  | int |  |
STARTTIME | 开始时间 |  |  | datetime |  |
ENDTIME | 结束时间 |  |  | datetime |  |
STATUS | 状态 | 1 |  | smallint |  |
CRUSERID | 创建托管的用户编号 |  |  | int |  | WCMUSER.USERID
CRTIME | 对象创建时间 |  |  | datetime |  |
MODULE | 托管的模块 |  |  | smallint |  |


WCMUSER

WCMUSER表：

描述：

用户信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
USERID | 编号 |  |  | int |  |
STATUS | 状态 |  |  | tinyint |  |
USERNAME | 用户名 |  |  | nvarchar | 50 |
PASSWORD | 密码 |  |  | nvarchar | 50 |
NICKNAME | 昵称 |  |  | nvarchar | 50 |
TRUENAME | 真实名称 |  |  | nvarchar | 64 |
ADDRESS | 联系地址 |  |  | nvarchar | 100 |
TEL | 联系电话 |  |  | nvarchar | 50 |
MOBILE | 联系移动电话 |  |  | nvarchar | 50 |
EMAIL | 电子邮件地址 |  |  | nvarchar | 1000 |
REMINDERQUESTION | 找回密码时的问题 |  |  | nvarchar | 100 |
REMINDERANSWER | 找回密码时的问题的答案 |  |  | nvarchar | 100 |
IFPUBMYINFO | 是否公开个人信息 |  |  | tinyint |  |
APPLYTIME | 开通时间 |  |  | datetime |  |
REGTIME | 注册时间 |  |  | datetime |  |
LOGINTIMES | 成功登录次数 | 0 |  | int |  |
LOGINTIME | 上次登录时间 |  |  | datetime |  |
LOGOUTTIME | 上次退出系统时间 |  |  | datetime |  |
MSGINTERVAL | 消息刷新时间间隔 |  |  | smallint |  |
VIEWINTERVAL | 页面刷新时间间隔 |  |  | smallint |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 |
CRTIME | 对象创建时间 |  |  | datetime |  |
PRICE | 用户稿费单价 | 0 |  | int |  |
ISDELETED | 是否已删除 | 0 |  | tinyint |  |


WCMUSERSETTING

WCMUSERSETTING表：

描述：

用户个性化定义

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SETTINGID | 编号 |  |  | int |  |
USERID | 用户编号 |  |  | int |  | WCMUSER.USERID
OBJTYPE | 定制对象的类型 |  |  | int |  |
OBJID | 定制对象的编号 |  |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 50 |
CRTIME | 对象创建时间 |  |  | datetime |  |
RANGEINDEX | 定制对象的范围 |  |  | int |  |
CVALUE | 定制对象的值 |  |  | nvarchar | 50 |
CRGION | 定制对象的显示区域 |  |  | int |  |


WCMWEBSITE

WCMWEBSITE表：

描述：

站点信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
SITEID | 编号 |  |  | int |  |
SITENAME | 名称(唯一标识) |  |  | nvarchar | 200 |
SITEDESC | 描述说明 |  |  | nvarchar | 200 |
FTPSERVER | 分发:FTP目标 |  |  | nvarchar | 200 | 分发
FTPUSER | 分发:FTP用户 |  |  | nvarchar | 50 |
FTPPASSWORD | 分发:FTP密码 |  |  | nvarchar | 50 |
FTPFOLDER | 分发:FTP存放目录 |  |  | nvarchar | 200 |
DATAPATH | 存放位置 |  |  | nvarchar | 200 | 发布设置
WEBHTTP | HTTP域 |  |  | nvarchar | 200 | 发布设置
SITEPROP | 站点属性 |  |  | int |  |
PARENTID | 父站点编号 |  |  | int |  |
SITEORDER | 序号 | 0 |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
HOMETEMPLATEID | 首页模板编号 |  |  | int |  | 模板
SITEORDERBY | 排序方式 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 50 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
PUBSTATUSES | 允许发布的文档状态 |  |  | varchar | 200 | 发布状态
SCHEDULE | 计划任务编号 | 0 |  | int |  | 计划任务
STATUS | 状态 | 0 |  | int |  |
PUBLISHPRO | 发布属性 | 1 |  | smallint |  | 保留
OPERUSER | 删除站点用户名 |  |  | nvarchar | 50 | WCMUSER.USERNAME
OPERTIME | 被删除的时间 |  |  | datetime |  |
SITETYPE | 类型 | 0 |  | int |  |

备注

  1. 分发:相关字段保留,信息见WCMPUBLISHDISTRIBUTION表
  2. 发布设置:相关字段保留,信息见WCMFOLDERPUBLISHCONFIG表
  3. 模板:保留,见WCMTEMPLATEEMPLOY表
  4. 发布状态:保留,见WCMPUBSTATUSCONFIG表
  5. 计划任务:计划任务


XWCMCLASSINFO

XWCMCLASSINFO表：

描述：

元数据选件:分类法

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CLASSINFOID | 编号 |  |  | int |  |
CLASSORDER | 序号 |  |  | int |  |
CNAME | 名称 | '0' |  | nvarchar | 50 |
CDESC | 描述说明 |  |  | nvarchar | 200 |
PARENTID | 父分类编号 | 0 |  | int |  |
ROOTID | 根分类编号 | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
CCODE | 分类标识码 |  |  | nvarchar | 50 |


XWCMCLASSINFOVIEW

XWCMCLASSINFOVIEW表：

描述：

元数据: 分类视图模式下的数据关联信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
CLASSINFOVIEWID | 编号 |  |  | int |  |
CLASSINFOID | 分类法编号 |  |  | int |  | WCMCLASSINFO.CLASSINFOID
METADATAID | 数据编号 |  |  | int |  | XWCMMETADATA.METADATAID
VIEWID | 视图编号 |  |  | int |  | XWCMVIEWINFO.VIEWINFOID
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMCOMPLEXFIELDDATA

XWCMCOMPLEXFIELDDATA表：

描述：

元数据:复杂字段数据

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
COMPLEXFIELDDATAID | 编号 |  |  | int |  |
INFOVIEWDATAID | --列说明-- | 0 |  | int |  |
FIELDNAME | --列说明-- |  |  | nvarchar | 200 |
FIELDID | --列说明-- |  |  | nvarchar | 200 |
FIELDVALUE | --列说明-- |  |  | nvarchar | 500 |
INFOVIEWID | --列说明-- | 0 |  | int |  |
PARENTFLAG | --列说明-- | '0' |  | nvarchar | 200 |
POSTTIME | --列说明-- |  |  | datetime |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
FIELDORDER | --列说明-- |  |  | int |  |


XWCMDBFIELDINFO

XWCMDBFIELDINFO表：

描述：

元数据:元数据表字段信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DBFIELDINFOID | 编号 |  |  | int |  |
TABLENAME | 表名 |  |  | nvarchar | 50 |
TABLEID | 元数据表编号 | 0 |  | int |  | XWCMTABLEINFO.TABLEINFOID
FIELDNAME | 名称 |  |  | nvarchar | 50 |
ANOTHERNAME | 显示名称 |  |  | nvarchar | 200 |
FIELDTYPE | 字段类型 |  |  | int |  |
DBTYPE | 字段实际数据库类型 | 0 |  | int |  |
DBLENGTH | 字段实际数据库长度 | 0 |  | int |  |
DEFAULTVALUE | 默认值 |  |  | nvarchar | 200 |
ENMVALUE | 枚举值 |  |  | nvarchar | 200 |
NOTNULL | 是否允许空值 |  |  | smallint |  |
CLASSID | 分类编号 | 0 |  | int |  |
DBSCALE | 数据库字段精度 | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
VALIDATOR | 校验器 |  |  | nvarchar | 200 |
RADORCHK | 单选或多选项 |  |  | smallint |  |
NOTEDIT | 是否不可编辑 | 0 |  | smallint |  |
HIDDENFIELD | 是否隐藏 | 0 |  | smallint |  |


XWCMDOCUMENTTOPIC

XWCMDOCUMENTTOPIC表：

描述：

文档评论

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
DOCUMENTTOPICID | 编号 |  |  | int |  |
TITLE | 标题 |  |  | nvarchar | 100 |
DESCRIPTION | 描述 |  |  | nvarchar | 250 |
CATEGORY | 分类 |  |  | int |  |
URL | 链接地址 |  |  | nvarchar | 500 |
CHANNELID | 所属栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMENTRYCONFIG

XWCMENTRYCONFIG表：

描述：

WCM选件系统配置

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
ENTRYCONFIGID | 编号 |  |  | int |  |
ENABLE | 选件是否启用 |  |  | smallint |  |
LINKPATH | 选件访问链接地址 |  |  | nvarchar | 250 |
ENTERDIRECTLY | 是否直接进入选件 |  |  | smallint |  |
TYPE | 类型 |  |  | int |  |
DESCRIPTION | 描述说明 |  |  | nvarchar | 250 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMFLOWACTION

XWCMFLOWACTION表：

描述：

工作流节点上执行的动作

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWACTIONID | 编号 |  |  | int |  |
PARAMS | 执行动作的相关参数 |  |  | nvarchar | 600 |
RULEID | 规则编号 | 0 |  | int |  | XWCMFLOWRULE.FLOWRULEID
HANDLER | 执行动作的处理者 | '0' |  | nvarchar | 100 | 执行者
ACTIONORDER | 执行次序 | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |

备注

  1. 执行者:com.trs.cms.process.engine.IActionHandler的具体实现类名


XWCMFLOWCONDITION

XWCMFLOWCONDITION表：

描述：

工作流操作条件

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWCONDITIONID | 编号 |  |  | int |  |
HANDLER | 执行者 | '0' |  | nvarchar | 100 |
PARAMNAME | 参数名称 | '0' |  | nvarchar | 50 |
PARAMVALUE | 参数值 |  |  | nvarchar | 50 |
RELATIONOPERATOR | 比较操作符 |  |  | nvarchar | 50 | 如大于,小于等
ISANDOPERATOR | 是否为与操作 | 1 |  | smallint |  |
RULEID | 规则编号 | 0 |  | int |  | XWCMFLOWRULE.FLOWRULEID
CONDITIONORDER | 序号 | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
UNITVALUE | 参数值单位 |  |  | nvarchar | 20 | 如时间单位:分钟


XWCMFLOWDOCLOG

XWCMFLOWDOCLOG表：

描述：

流转文档日志记录

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWDOCLOGID | 编号 |  |  | int |  |
POSTUSER | 逞送用户 |  |  | nvarchar | 50 |
ACTIONDESC | 动作描述 |  |  | nvarchar | 200 |
ACTIONFLAG | 动作标记 |  |  | int |  |
OBJID | 对象编号 |  |  | int |  |
OBJTYPE | 对象类型 |  |  | int |  |
CHANNELID | 所属栏目编号 |  |  | int |  | WCMCHANNEL.CHANNELID
SITEID | 所属站点编号 |  |  | int |  | WCMWEBSITE.SITEID
FLOWDOCID | 流转文档编号 |  |  | int |  | WCMFLOWDOC.FLOWDOCID
USERGROUPID | 逞送用户所在组织编号 |  |  | int |  | WCMGROUP.GROUPID
STARTING | 是否已经开始流转 |  |  | smallint |  |
BRANCHID | 分支编号 |  |  | int |  | WCMFLOWBRANCH.BRANCHID
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMFLOWNODEFIELD

XWCMFLOWNODEFIELD表：

描述：

工流节点相关字段(自定义表单)

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWNODEFIELDID | 编号 |  |  | int |  |
FLOWID | 工作流编号 | 0 |  | int |  | WCMFLOW.FLOWID
NODEID | 节点编号 | 0 |  | int |  | WCMFLOWNODE.NODEID
FIELDNAME | 字段名称 | '0' |  | nvarchar | 100 |
FIELDDESC | 字段说明 | '0' |  | nvarchar | 100 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
WRITEFIELD | 字段是否可写 | 0 |  | int |  |
READFIELD | 字段是否可读 | 0 |  | int |  |
INITVALUE | 初始值 |  |  | nvarchar | 200 |
INITVALUECREATOR | 初始值创建者 |  |  | nvarchar | 100 |
FIELDTYPE | 字段类型 | 0 |  | int |  |

备注

  1. 实现自定义表单在流程中的字段级的权限控制


XWCMFLOWRULE

XWCMFLOWRULE表：

描述：

工作流规则

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
FLOWRULEID | 编号 |  |  | int |  |
RULENAME | 名称 | '0' |  | nvarchar | 50 |
RULETYPE | 规则类型 | 0 |  | int |  |
HOSTTYPE | 属主对象类型 | 0 |  | int |  |
HOSTID | 属主对象编号 | 0 |  | int |  |
RULEORDER | 序号 | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMINDIVIDUATION

XWCMINDIVIDUATION表：

描述：

--表描述--

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
INDIVIDUATIONID | --列说明-- |  |  | int |  |
USERID | --列说明-- |  |  | int |  |
ATTRIBUTE | 扩展属性 |  |  | nvarchar | 500 |
PARAMNAME | --列说明-- |  |  | nvarchar | 500 |
PARAMVALUE | --列说明-- |  |  | nvarchar | 500 |
OBJECTIDSVALUE | --列说明-- |  |  | nvarchar | 400 |
ISCHECKED | --列说明-- |  |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMLOGO

XWCMLOGO表：

描述：

栏目/文档标记图信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
LOGOID | 编号 |  |  | int |  |
HOSTTYPE | 所属对象类型 | 0 |  | int |  |
HOSTID | 所属对象编号 | 0 |  | int |  |
FILENAME | 图片对应系统文件名 | '0' |  | nvarchar | 50 |
LOGOORDER | 序号 |  |  | int |  |
UPDATED | 是否有更新 |  |  | smallint |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMMETADATA

XWCMMETADATA表：

描述：

元数据:元数据数据关联信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
METADATAID | 编号 |  |  | int |  | WCMDOCUMENT.DOCID
VIEWID | 关联视图编号 | 0 |  | int |  | XWCMVIEWINFO.VIEWINFOID
CHANNELID | 关联栏目编号 | 0 |  | int |  | WCMCHANNEL.CHANNELID
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |


XWCMMETAVIEWEMPLOYER

XWCMMETAVIEWEMPLOYER表：

描述：

元数据:视图与栏目的关联信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
METAVIEWEMPLOYERID | 编号 |  |  | int |  |
VIEWID | 视图编号 | 0 |  | int |  | XWCMVIEWINFO.VIEWINFOID
CHANNELID | 栏目编号 | 0 |  | int |  | WCMCHANNEL.CHANNELID


XWCMPAGEOPERATOR

XWCMPAGEOPERATOR表：

描述：

面板操作设置

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
PAGEOPERATORID | 编号 |  |  | int |  |
OPRNAME | 名称 |  |  | nvarchar | 50 |
OPRKEY | 操作标识键 |  |  | nvarchar | 50 |
OPRDESC | 描述说明 |  |  | nvarchar | 100 |
OPRTYPE | 操作类型 |  |  | nvarchar | 20 |
RIGHTINDEX | 权限索引 | 64 |  | int |  |
ISDISPLAY | 是否显示 | 0 |  | int |  |
OPRORDER | 序号 | 0 |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |

备注

  1. V61不再使用


XWCMTABLEINFO

XWCMTABLEINFO表：

描述：

元数据:元数据表信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TABLEINFOID | 编号 |  |  | int |  |
TABLENAME | 名称 |  |  | nvarchar | 50 |
ANOTHERNAME | 显示名称 |  |  | nvarchar | 100 |
TABLEDESC | 描述说明 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
OWNERTYPE | 所属对对象类型 | 1 |  | int |  |
OWNERID | 所属对对象编号 | 4 |  | int |  |


XWCMTOPICEDDOCRELATION

XWCMTOPICEDDOCRELATION表：

描述：

文档与文档评论的关联关系

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
TOPICEDDOCRELATIONID | 编号 |  |  | int |  |
DOCUMENTID | 文档编号 |  |  | int |  | WCMDOCUMENT.DOCUMENTID
TOPICID | 评论ID |  |  | int |  | XWCMDOCUMENTTOPIC.DOCUMENTTOPICID
DESCRIPTION | 描述 |  |  | nvarchar | 250 |
DOCCHANNELID | 文档所属栏目编号 |  |  | int |  |


XWCMVIEWFIELDINFO

XWCMVIEWFIELDINFO表：

描述：

元数据:视图字段信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
VIEWFIELDINFOID | 编号 |  |  | int |  |
TABLENAME | 对应元数据表名 |  |  | nvarchar | 50 |
TABLEID | 对应元数据表编号 | 0 |  | int |  | XWCMTABLEINFO.TABLEINFOID
FIELDNAME | 字段名称 |  |  | nvarchar | 50 |
DBFIELDNAME | 物理字段名称 |  |  | nvarchar | 50 |
DBTYPE | 实际数据库类型 | 0 |  | int |  |
DBLENGTH | 实际数据库长度 | 0 |  | int |  |
ANOTHERNAME | 显示名称 |  |  | nvarchar | 200 |
FIELDTYPE | 逻辑类型 | 0 |  | int |  |
DEFAULTVALUE | 默认值 |  |  | nvarchar | 200 |
ENMVALUE | 枚举值 |  |  | nvarchar | 200 |
NOTNULL | 是否允许空值 |  |  | smallint |  |
CLASSID | 分类编号 | 0 |  | int |  |
VIEWID | 关联视图编号 | 0 |  | int |  |
FIELDORDER | 序号 | 0 |  | int |  |
INOUTLINE | 是否可概览列表显示 |  |  | smallint |  |
INDETAIL | 是否可细览详细信息查看 | 1 |  | smallint |  |
SEARCHFIELD | 是否可检索 |  |  | smallint |  |
TITLEFIELD | 是否是标题字段 |  |  | smallint |  |
DBFIELD | 元数据表字段编号 | 0 |  | int |  |
VALIDATOR | 校验器 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
FROMMAINTABLE | 是否是主表字段 | 1 |  | int |  |
LOCATECHANNEL | --列说明-- |  |  | nvarchar | 100 |
RADORCHK | 单选或多选项 |  |  | smallint |  |
NOTEDIT | 是否可编辑 | 0 |  | smallint |  |
HIDDENFIELD | 是否隐藏 | 0 |  | smallint |  |
INMULTITABLE | 是否是多表视图 | 1 |  | smallint |  |


XWCMVIEWINFO

XWCMVIEWINFO表：

描述：

元数据:视图信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
VIEWINFOID | 编号 |  |  | int |  |
VIEWNAME | 名称 |  |  | nvarchar | 100 |
VIEWDESC | 描述说明 |  |  | nvarchar | 400 |
MAINTABLENAME | 主表名 |  |  | nvarchar | 50 |
MAINTABLEID | 主表编号 |  |  | int |  |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |
OWNERTYPE | 所属对象类型 | 1 |  | int |  |
OWNERID | 所属对象编号 | 4 |  | int |  |
HIDDENAPPENDIX | 隐藏附件管理 | 0 |  | smallint |  |


XWCMVIEWOTHERTABLES

XWCMVIEWOTHERTABLES表：

描述：

元数据:视图与非主表关联信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
VIEWID | 视图编号 |  |  | int |  |
TABLEID | 元数据表编号 |  |  | int |  |


XWCMWATERMARK

XWCMWATERMARK表：

描述：

图片库:水印信息

结构：

列名 | 说明 | 默认值 | 允许空值 | 类型 | 长度 | 备注
WATERMARKID | 编号 |  |  | int |  |
LIBID | 所属站点编号 |  |  | int |  |
WMNAME | 名称 |  |  | nvarchar | 200 |
WMPICTURE | 水印对应图片文件名 |  |  | nvarchar | 200 |
CRUSER | 对象创建者 |  |  | nvarchar | 30 | WCMUSER.USERNAME
CRTIME | 对象创建时间 |  |  | datetime |  |